Bläddra i källkod

Import libvorbisidec from oldpackages

Ted Hess 10 år sedan
förälder
incheckning
f218947804
1 ändrade filer med 56 tillägg och 0 borttagningar
  1. 56
    0
      libs/libvorbisidec/Makefile

+ 56
- 0
libs/libvorbisidec/Makefile Visa fil

@@ -0,0 +1,56 @@
1
+#
2
+# Copyright (C) 2006-2011 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=libvorbisidec
11
+PKG_VERSION:=1.0.2+svn18153
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
15
+PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/libv/libvorbisidec/
16
+PKG_MD5SUM:=4190859414c5d6760e316b5cf00fe7c5
17
+
18
+PKG_LICENSE:=BSD-3c
19
+PKG_LICENSE_FILES:=COPYING
20
+
21
+PKG_FIXUP:=autoreconf
22
+PKG_INSTALL:=1
23
+
24
+include $(INCLUDE_DIR)/package.mk
25
+
26
+define Package/libvorbisidec
27
+  SECTION:=libs
28
+  CATEGORY:=Libraries
29
+  TITLE:=A fixed-point Ogg/Vorbis decoder library
30
+  DEPENDS:= +libogg
31
+  URL:=http://wiki.xiph.org/index.php/Tremor
32
+endef
33
+
34
+define Package/libvorbisidec/description
35
+	libvorbisidec is "tremor", a fixed-point implementation of libvorbis.
36
+	It also has libogg built-in. It is suitable as a replacement for
37
+	libvorbis and libogg in tremor-aware applications.
38
+	Tremor is a decoder only.
39
+endef
40
+
41
+TARGET_CFLAGS += $(FPIC)
42
+CONFIGURE_ARGS += --enable-shared --enable-static
43
+
44
+define Build/InstallDev
45
+	$(INSTALL_DIR) $(1)/usr/include
46
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/tremor $(1)/usr/include/
47
+	$(INSTALL_DIR) $(1)/usr/lib
48
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.{a,so*} $(1)/usr/lib/
49
+endef
50
+
51
+define Package/libvorbisidec/install
52
+	$(INSTALL_DIR) $(1)/usr/lib
53
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.so.* $(1)/usr/lib/
54
+endef
55
+
56
+$(eval $(call BuildPackage,libvorbisidec))