|
@@ -0,0 +1,69 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2006-2011 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=iodine
|
|
11
|
+PKG_VERSION:=0.6.0-rc1
|
|
12
|
+PKG_RELEASE:=5
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
15
|
+PKG_SOURCE_URL:=http://code.kryo.se/iodine/
|
|
16
|
+PKG_MD5SUM:=a15bb4faba020d217016fde6e231074a
|
|
17
|
+
|
|
18
|
+include $(INCLUDE_DIR)/package.mk
|
|
19
|
+
|
|
20
|
+define Package/iodine/Default
|
|
21
|
+ SECTION:=net
|
|
22
|
+ CATEGORY:=Network
|
|
23
|
+ SUBMENU:=Firewall Tunnel
|
|
24
|
+ DEPENDS:= +kmod-tun +zlib
|
|
25
|
+ TITLE:=IP over DNS tunneling
|
|
26
|
+ URL:=http://code.kryo.se/iodine/
|
|
27
|
+endef
|
|
28
|
+
|
|
29
|
+define Package/iodine
|
|
30
|
+ $(call Package/iodine/Default)
|
|
31
|
+ TITLE+= client version
|
|
32
|
+endef
|
|
33
|
+
|
|
34
|
+define Package/iodine/description
|
|
35
|
+ iodine client version
|
|
36
|
+endef
|
|
37
|
+
|
|
38
|
+define Package/iodined
|
|
39
|
+ $(call Package/iodine/Default)
|
|
40
|
+ TITLE+= server version
|
|
41
|
+endef
|
|
42
|
+
|
|
43
|
+define Package/iodined/description
|
|
44
|
+ iodine server version
|
|
45
|
+endef
|
|
46
|
+
|
|
47
|
+define Build/Configure
|
|
48
|
+endef
|
|
49
|
+
|
|
50
|
+define Package/iodine/install
|
|
51
|
+ $(INSTALL_DIR) $(1)/usr/sbin
|
|
52
|
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/iodine $(1)/usr/sbin
|
|
53
|
+endef
|
|
54
|
+
|
|
55
|
+define Package/iodined/install
|
|
56
|
+ $(INSTALL_DIR) $(1)/etc/init.d
|
|
57
|
+ $(INSTALL_BIN) ./files/iodined.init $(1)/etc/init.d/iodined
|
|
58
|
+ $(INSTALL_DIR) $(1)/etc/config
|
|
59
|
+ $(INSTALL_DATA) ./files/iodined.config $(1)/etc/config/iodined
|
|
60
|
+ $(INSTALL_DIR) $(1)/usr/sbin
|
|
61
|
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/iodined $(1)/usr/sbin
|
|
62
|
+endef
|
|
63
|
+
|
|
64
|
+define Package/iodined/conffiles
|
|
65
|
+/etc/config/iodined
|
|
66
|
+endef
|
|
67
|
+
|
|
68
|
+$(eval $(call BuildPackage,iodine))
|
|
69
|
+$(eval $(call BuildPackage,iodined))
|