ソースを参照

net/iodine: import from old packages

No further changes.
Uwe Kleine-König 10 年 前
コミット
f22fc16043
共有4 個のファイルを変更した119 個の追加0 個の削除を含む
  1. 69
    0
      net/iodine/Makefile
  2. 5
    0
      net/iodine/files/iodined.config
  3. 23
    0
      net/iodine/files/iodined.init
  4. 22
    0
      net/iodine/patches/010-cross-compile.patch

+ 69
- 0
net/iodine/Makefile ファイルの表示

@@ -0,0 +1,69 @@
1
+#
2
+# Copyright (C) 2006-2011 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=iodine
11
+PKG_VERSION:=0.6.0-rc1
12
+PKG_RELEASE:=5
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=http://code.kryo.se/iodine/
16
+PKG_MD5SUM:=a15bb4faba020d217016fde6e231074a
17
+
18
+include $(INCLUDE_DIR)/package.mk
19
+
20
+define Package/iodine/Default
21
+  SECTION:=net
22
+  CATEGORY:=Network
23
+  SUBMENU:=Firewall Tunnel
24
+  DEPENDS:= +kmod-tun +zlib
25
+  TITLE:=IP over DNS tunneling
26
+  URL:=http://code.kryo.se/iodine/
27
+endef
28
+
29
+define Package/iodine
30
+  $(call Package/iodine/Default)
31
+  TITLE+= client version
32
+endef
33
+
34
+define Package/iodine/description
35
+ iodine client version
36
+endef
37
+
38
+define Package/iodined
39
+  $(call Package/iodine/Default)
40
+  TITLE+= server version
41
+endef
42
+
43
+define Package/iodined/description
44
+ iodine server version
45
+endef
46
+
47
+define Build/Configure
48
+endef
49
+
50
+define Package/iodine/install
51
+	$(INSTALL_DIR) $(1)/usr/sbin
52
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/iodine $(1)/usr/sbin
53
+endef
54
+
55
+define Package/iodined/install
56
+	$(INSTALL_DIR) $(1)/etc/init.d
57
+	$(INSTALL_BIN) ./files/iodined.init $(1)/etc/init.d/iodined
58
+	$(INSTALL_DIR) $(1)/etc/config
59
+	$(INSTALL_DATA) ./files/iodined.config $(1)/etc/config/iodined
60
+	$(INSTALL_DIR) $(1)/usr/sbin
61
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/iodined $(1)/usr/sbin
62
+endef
63
+
64
+define Package/iodined/conffiles
65
+/etc/config/iodined
66
+endef
67
+
68
+$(eval $(call BuildPackage,iodine))
69
+$(eval $(call BuildPackage,iodined))

+ 5
- 0
net/iodine/files/iodined.config ファイルの表示

@@ -0,0 +1,5 @@
1
+config iodined
2
+        option address     ''
3
+        option password    ''
4
+        option tunnelip    '10.0.0.1'
5
+        option tld     	   ''

+ 23
- 0
net/iodine/files/iodined.init ファイルの表示

@@ -0,0 +1,23 @@
1
+#!/bin/sh /etc/rc.common
2
+# Copyright (C) 2006-2011 OpenWrt.org
3
+
4
+START=50
5
+
6
+start_instance () {
7
+	local section="$1"
8
+	config_get address  "$section" 'address'
9
+	config_get password "$section" 'password'
10
+	config_get tunnelip "$section" 'tunnelip'
11
+	config_get tld      "$section" 'tld'
12
+	
13
+	service_start /usr/sbin/iodined -l "$address" -P "$password" "$tunnelip" "$tld"
14
+}
15
+
16
+start() {
17
+	config_load 'iodined'
18
+	config_foreach start_instance 'iodined'
19
+}
20
+
21
+stop() {
22
+	service_stop /usr/sbin/iodined
23
+}

+ 22
- 0
net/iodine/patches/010-cross-compile.patch ファイルの表示

@@ -0,0 +1,22 @@
1
+--- a/src/osflags
2
++++ b/src/osflags
3
+@@ -16,9 +16,6 @@ link)
4
+ 		windows32)
5
+ 			echo '-lws2_32 -liphlpapi';
6
+ 		;;
7
+-		Linux)
8
+-			[ -e /usr/include/selinux/selinux.h ] && echo '-lselinux';
9
+-		;;
10
+ 	esac
11
+ 	;;
12
+ cflags)
13
+@@ -26,9 +23,6 @@ cflags)
14
+ 		BeOS)
15
+ 			echo '-Dsocklen_t=int';
16
+ 		;;
17
+-		Linux)
18
+-			[ -e /usr/include/selinux/selinux.h ] && echo '-DHAVE_SETCON';
19
+-		;;
20
+ 	esac
21
+ ;;
22
+ *)