Browse Source

zip: respect LDFLAGS

Signed-off-by: Alexander Ryzhov <openwrt@ryzhov-al.ru>
Alexander Ryzhov 9 years ago
parent
commit
f326e41ade
1 changed files with 3 additions and 4 deletions
  1. 3
    4
      utils/zip/Makefile

+ 3
- 4
utils/zip/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2007-2014 OpenWrt.org
2
+# Copyright (C) 2007-2016 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
10 10
 PKG_NAME:=zip
11 11
 PKG_REV:=30
12 12
 PKG_VERSION:=3.0
13
-PKG_RELEASE:=1
13
+PKG_RELEASE:=2
14 14
 
15 15
 PKG_SOURCE:=$(PKG_NAME)$(PKG_REV).tar.gz
16 16
 PKG_SOURCE_URL:=@SF/infozip
@@ -48,8 +48,7 @@ define Build/Compile
48 48
 	$(MAKE) -C $(PKG_BUILD_DIR) -f unix/Makefile generic \
49 49
 		prefix="$(PKG_INSTALL_DIR)/usr" \
50 50
 		CFLAGS="$(TARGET_CFLAGS)" \
51
-		CC="$(TARGET_CC) $(TARGET_CFLAGS) -O $(TARGET_CPPFLAGS) -I. -DUNIX" \
52
-		LD="$(TARGET_CC) $(TARGET_LDFLAGS)" \
51
+		CC="$(TARGET_CC) $(TARGET_CFLAGS) -O $(TARGET_CPPFLAGS) -I. -DUNIX $(TARGET_LDFLAGS)" \
53 52
 		IZ_BZIP2="no" \
54 53
 		install
55 54
 endef