|
@@ -1,15 +1,3 @@
|
1
|
|
|
2
|
|
-+++ b/configure.ac
|
3
|
|
-@@ -58,9 +58,6 @@
|
4
|
|
- [build_tools=$withval], [build_tools=yes])
|
5
|
|
-
|
6
|
|
- AM_CONDITIONAL(BUILD_TOOLS, [test "x$build_tools" = "xyes" ])
|
7
|
|
--if test x$build_tools = xyes ; then
|
8
|
|
-- PKG_CHECK_MODULES(png, "libpng")
|
9
|
|
--fi
|
10
|
|
-
|
11
|
|
- dnl --with-tests
|
12
|
|
- AC_ARG_WITH([tests], [AS_HELP_STRING([--with-tests], [build tests [default=no]])],
|
13
|
1
|
--- a/qrenc.c
|
14
|
2
|
+++ b/qrenc.c
|
15
|
3
|
@@ -25,7 +25,6 @@
|
|
@@ -291,3 +279,28 @@
|
291
|
279
|
if(optind < argc) {
|
292
|
280
|
intext = (unsigned char *)argv[optind];
|
293
|
281
|
length = strlen((char *)intext);
|
|
282
|
+--- a/configure.ac
|
|
283
|
|
|
284
|
+@@ -58,9 +58,6 @@
|
|
285
|
+ [build_tools=$withval], [build_tools=yes])
|
|
286
|
+
|
|
287
|
+ AM_CONDITIONAL(BUILD_TOOLS, [test "x$build_tools" = "xyes" ])
|
|
288
|
+-if test x$build_tools = xyes ; then
|
|
289
|
+- PKG_CHECK_MODULES(png, "libpng")
|
|
290
|
+-fi
|
|
291
|
+
|
|
292
|
+ dnl --with-tests
|
|
293
|
+ AC_ARG_WITH([tests], [AS_HELP_STRING([--with-tests], [build tests [default=no]])],
|
|
294
|
+@@ -80,12 +77,6 @@
|
|
295
|
+ echo "/* #undef WITH_TESTS */" >>confdefs.h
|
|
296
|
+ fi
|
|
297
|
+
|
|
298
|
+-if test x$build_tests = xyes ; then
|
|
299
|
+- SDL_REQUIRED_VERSION=1.2.0
|
|
300
|
+- AM_PATH_SDL($SDL_REQUIRED_VERSION,,AC_MSG_WARN([*** SDL $SDL_REQUIRED_VERSION or better is required.]))
|
|
301
|
+- AC_MSG_NOTICE([SDL check done.])
|
|
302
|
+- AM_ICONV_LINK
|
|
303
|
+-fi
|
|
304
|
+ AM_CONDITIONAL(HAVE_SDL, [test "x$SDL_CFLAGS" != "x" ])
|
|
305
|
+
|
|
306
|
+
|