瀏覽代碼

libqrencode: fix typo in makefile

Fix compile error due to autoconf
Signed-off-by: Jonathan Bennett <jbennett@incomsystems.biz>
Jonathan Bennett 9 年之前
父節點
當前提交
f51adfc331
共有 2 個文件被更改,包括 27 次插入14 次删除
  1. 2
    2
      libs/qrencode/Makefile
  2. 25
    12
      libs/qrencode/patches/001-disable-png.patch

+ 2
- 2
libs/qrencode/Makefile 查看文件

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=qrencode
11 11
 PKG_VERSION:=3.4.4
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://fukuchi.org/works/qrencode/
@@ -17,7 +17,7 @@ PKG_MD5SUM:=be545f3ce36ea8fbb58612d72c4222de
17 17
 PKG_MAINTAINER:=Jonathan Bennett <JBennett@incomsystems.biz>
18 18
 PKG_LICENSE:=LGPL-2.1+
19 19
 PKG_INSTALL:=1
20
-PKG:FIXUP:=autoreconf
20
+PKG_FIXUP:=autoreconf
21 21
 
22 22
 include $(INCLUDE_DIR)/package.mk
23 23
 

+ 25
- 12
libs/qrencode/patches/001-disable-png.patch 查看文件

@@ -1,15 +1,3 @@
1
---- a/configure.ac
2
-+++ b/configure.ac
3
-@@ -58,9 +58,6 @@
4
-  [build_tools=$withval], [build_tools=yes])
5
- 
6
- AM_CONDITIONAL(BUILD_TOOLS, [test "x$build_tools" = "xyes" ])
7
--if test x$build_tools = xyes ; then
8
--	PKG_CHECK_MODULES(png, "libpng")
9
--fi
10
- 
11
- dnl --with-tests
12
- AC_ARG_WITH([tests], [AS_HELP_STRING([--with-tests], [build tests [default=no]])],
13 1
 --- a/qrenc.c
14 2
 +++ b/qrenc.c
15 3
 @@ -25,7 +25,6 @@
@@ -291,3 +279,28 @@
291 279
  	if(optind < argc) {
292 280
  		intext = (unsigned char *)argv[optind];
293 281
  		length = strlen((char *)intext);
282
+--- a/configure.ac
283
++++ b/configure.ac
284
+@@ -58,9 +58,6 @@
285
+  [build_tools=$withval], [build_tools=yes])
286
+ 
287
+ AM_CONDITIONAL(BUILD_TOOLS, [test "x$build_tools" = "xyes" ])
288
+-if test x$build_tools = xyes ; then
289
+-	PKG_CHECK_MODULES(png, "libpng")
290
+-fi
291
+ 
292
+ dnl --with-tests
293
+ AC_ARG_WITH([tests], [AS_HELP_STRING([--with-tests], [build tests [default=no]])],
294
+@@ -80,12 +77,6 @@
295
+ echo "/* #undef WITH_TESTS */" >>confdefs.h
296
+ fi
297
+ 
298
+-if test x$build_tests = xyes ; then
299
+-	SDL_REQUIRED_VERSION=1.2.0
300
+-	AM_PATH_SDL($SDL_REQUIRED_VERSION,,AC_MSG_WARN([*** SDL $SDL_REQUIRED_VERSION or better is required.]))
301
+-	AC_MSG_NOTICE([SDL check done.])
302
+-	AM_ICONV_LINK
303
+-fi
304
+ AM_CONDITIONAL(HAVE_SDL, [test "x$SDL_CFLAGS" != "x" ])
305
+ 
306
+