Преглед на файлове

Merge pull request #1030 from giner/patch-2

wshaper: start wshaper on ifup
Jo-Philipp Wich преди 10 години
родител
ревизия
f55314de0e
променени са 2 файла, в които са добавени 5 реда и са изтрити 1 реда
  1. 2
    1
      net/wshaper/Makefile
  2. 3
    0
      net/wshaper/files/wshaper.iface

+ 2
- 1
net/wshaper/Makefile Целия файл

@@ -44,9 +44,10 @@ define Build/Compile
44 44
 endef
45 45
 
46 46
 define Package/wshaper/install
47
-	$(INSTALL_DIR) $(1)/usr/sbin/ $(1)/etc/init.d $(1)/etc/config
47
+	$(INSTALL_DIR) $(1)/usr/sbin/ $(1)/etc/init.d $(1)/etc/config $(1)/etc/hotplug.d/iface
48 48
 	$(INSTALL_BIN) ./files/wshaper.htb $(1)/usr/sbin/
49 49
 	$(INSTALL_BIN) ./files/wshaper.init $(1)/etc/init.d/wshaper
50
+	$(INSTALL_BIN) ./files/wshaper.iface $(1)/etc/hotplug.d/iface/10-wshaper
50 51
 	$(INSTALL_DATA) ./files/wshaper.config $(1)/etc/config/wshaper
51 52
 endef
52 53
 

+ 3
- 0
net/wshaper/files/wshaper.iface Целия файл

@@ -0,0 +1,3 @@
1
+#!/bin/sh
2
+
3
+[ "$ACTION" = ifup ] && /etc/init.d/wshaper enabled && /etc/init.d/wshaper start || exit 0