Browse Source

ocserv: install missing ocserv-script

Nikos Mavrogiannopoulos 10 years ago
parent
commit
f5e6eced6e
2 changed files with 2 additions and 1 deletions
  1. 1
    0
      net/ocserv/Makefile
  2. 1
    1
      net/ocserv/files/ocserv-script

+ 1
- 0
net/ocserv/Makefile View File

@@ -67,6 +67,7 @@ define Package/ocserv/install
67 67
 	$(INSTALL_DIR) $(1)/usr/bin
68 68
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ocpasswd $(1)/usr/bin/
69 69
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/occtl $(1)/usr/bin/
70
+	$(INSTALL_BIN) ./files/ocserv-script $(1)/usr/bin/
70 71
 	$(INSTALL_DIR) $(1)/etc/init.d
71 72
 	$(INSTALL_BIN) ./files/ocserv.init $(1)/etc/init.d/ocserv
72 73
 	$(INSTALL_DIR) $(1)/etc/ocserv

+ 1
- 1
net/ocserv/files/ocserv-script View File

@@ -1,6 +1,6 @@
1 1
 #!/bin/sh
2 2
 
3
-ZONE=`uci get ocserv.config.ZONE`
3
+ZONE=`uci get ocserv.config.zone`
4 4
 
5 5
 if [ "$REASON" = "connect" ];then
6 6
 	env -i ACTION=ifup INTERFACE="$ZONE" DEVICE=$DEVICE /sbin/hotplug-call "iface"