Browse Source

python: fix source folder for libpython

This fix is quite critical since it fixes copying the libpython shared lib.
The previous source folder we've used is ok, it has the shared lib,
but libpython2.7.so is not a symlink of libpython2.7.so.1.0, but
rather a copy of it.
Which means that libpython2.7.so takes twice as much space
on the target's flash.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Alexandru Ardelean 10 years ago
parent
commit
f699a1f8f9
1 changed files with 2 additions and 2 deletions
  1. 2
    2
      lang/python/Makefile

+ 2
- 2
lang/python/Makefile View File

@@ -176,7 +176,7 @@ define Build/InstallDev
176 176
 		$(1)/usr/include/
177 177
 	$(CP) \
178 178
 		$(STAGING_DIR_HOST)/lib/python$(PYTHON_VERSION) \
179
-		$(PKG_BUILD_DIR)/libpython$(PYTHON_VERSION).so* \
179
+		$(PKG_INSTALL_DIR)/usr/lib/libpython$(PYTHON_VERSION).so* \
180 180
 		$(1)/usr/lib/
181 181
 	$(CP) \
182 182
 		$(PKG_INSTALL_DIR)/usr/lib/python$(PYTHON_VERSION)/config \
@@ -389,7 +389,7 @@ endef
389 389
 define PyPackage/python/install
390 390
 	$(LN) python$(PYTHON_VERSION) $(1)/usr/bin/python
391 391
 	$(LN) python$(PYTHON_VERSION) $(1)/usr/bin/python2
392
-	$(CP) $(PKG_BUILD_DIR)/libpython$(PYTHON_VERSION).so* $(1)/usr/lib/
392
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpython$(PYTHON_VERSION).so* $(1)/usr/lib/
393 393
 endef
394 394
 
395 395
 define PyPackage/python-doc/filespec