Bladeren bron

libxslt: import from oldpackages

Signed-off-by: Jiri Slachta <slachta@cesnet.cz>
Jiri Slachta 10 jaren geleden
bovenliggende
commit
f6d2c55587
1 gewijzigde bestanden met toevoegingen van 149 en 0 verwijderingen
  1. 149
    0
      libs/libxslt/Makefile

+ 149
- 0
libs/libxslt/Makefile Bestand weergeven

@@ -0,0 +1,149 @@
1
+#
2
+# Copyright (C) 2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=libxslt
11
+PKG_VERSION:=1.1.28
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:= \
16
+¨	http://xmlsoft.org/sources/ \
17
+	ftp://fr.rpmfind.net/pub/libxml/
18
+PKG_MD5SUM:=9667bf6f9310b957254fdcf6596600b7
19
+
20
+PKG_MAINTAINER:=Jiri Slachta <slachta@cesnet.cz>
21
+
22
+PKG_FIXUP:=autoreconf
23
+PKG_INSTALL:=1
24
+
25
+include $(INCLUDE_DIR)/package.mk
26
+
27
+define Package/libxslt
28
+  SECTION:=libs
29
+  CATEGORY:=Libraries
30
+  DEPENDS:=+libxml2
31
+  TITLE:=Gnome XSLT library
32
+  URL:=http://xmlsoft.org/XSLT/
33
+endef
34
+
35
+define Package/libxslt/description
36
+ A library for XML transformation using XSLT.
37
+endef
38
+
39
+define Package/libexslt
40
+  SECTION:=libs
41
+  CATEGORY:=Libraries
42
+  DEPENDS:=+libxslt
43
+  TITLE:=Gnome XSLT library Extention
44
+  URL:=http://xmlsoft.org/XSLT/EXSLT/
45
+endef
46
+
47
+define Package/libexslt/description
48
+ A extention for XSLT.
49
+endef
50
+
51
+define Package/xsltproc
52
+  SECTION:=utils
53
+  CATEGORY:=Utilities
54
+  DEPENDS:=+libxml2 +libxslt +libexslt
55
+  TITLE:=Gnome XSLT xsltproc Utility
56
+  URL:=http://xmlsoft.org/XSLT/
57
+endef
58
+
59
+define Package/xsltproc/description
60
+ XSLT XML transformation utility.
61
+endef
62
+
63
+CONFIGURE_ARGS+= \
64
+	--enable-shared \
65
+	--enable-static \
66
+	--without-python \
67
+	--without-crypto \
68
+	--without-debug \
69
+	--without-mem-debug \
70
+	--without-debugger \
71
+
72
+TARGET_CFLAGS += $(FPIC)
73
+
74
+define Build/InstallDev/Xslt
75
+	$(INSTALL_DIR) $(1)/usr/bin $(2)/bin $(1)/usr/include/libxslt \
76
+		$(1)/usr/include/libexslt $(1)/usr/lib \
77
+		$(1)/usr/lib/pkgconfig $(2)/share/aclocal
78
+
79
+	$(INSTALL_BIN) \
80
+		$(PKG_INSTALL_DIR)/usr/bin/xslt-config \
81
+		$(2)/bin/
82
+
83
+	ln -sf $(STAGING_DIR)/host/bin/xslt-config $(1)/usr/bin/xslt-config
84
+
85
+	$(SED) \
86
+		's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
87
+		$(2)/bin/xslt-config
88
+
89
+	$(INSTALL_DATA) \
90
+		$(PKG_INSTALL_DIR)/usr/include/libxslt/* \
91
+		$(1)/usr/include/libxslt/
92
+
93
+	$(CP) \
94
+		$(PKG_INSTALL_DIR)/usr/lib/libxslt.{la,a,so*} \
95
+		$(1)/usr/lib/
96
+
97
+	$(INSTALL_DATA) \
98
+		$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libxslt.pc \
99
+		$(1)/usr/lib/pkgconfig/
100
+
101
+	$(INSTALL_DATA) \
102
+		$(PKG_INSTALL_DIR)/usr/share/aclocal/* \
103
+		$(2)/share/aclocal
104
+endef
105
+
106
+define Build/InstallDev/Exslt
107
+	$(INSTALL_DIR) $(1)/usr/include/libexslt $(1)/usr/lib/pkgconfig
108
+	$(INSTALL_DATA) \
109
+		$(PKG_INSTALL_DIR)/usr/include/libexslt/* \
110
+		$(1)/usr/include/libexslt/
111
+
112
+	$(CP) \
113
+		$(PKG_INSTALL_DIR)/usr/lib/libexslt.{la,a,so*} \
114
+		$(1)/usr/lib/
115
+
116
+	$(INSTALL_DATA) \
117
+		$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libexslt.pc \
118
+		$(1)/usr/lib/pkgconfig/
119
+endef
120
+
121
+define Build/InstallDev
122
+	 $(if $(CONFIG_PACKAGE_libxslt),$(call Build/InstallDev/Xslt,$(1),$(2)))
123
+	 $(if $(CONFIG_PACKAGE_libexslt),$(call Build/InstallDev/Exslt,$(1),$(2)))
124
+endef
125
+
126
+define Package/libxslt/install
127
+	$(INSTALL_DIR) $(1)/usr/lib
128
+	$(CP) \
129
+		$(PKG_INSTALL_DIR)/usr/lib/libxslt.so.* \
130
+		$(1)/usr/lib/
131
+endef
132
+
133
+define Package/libexslt/install
134
+	$(INSTALL_DIR) $(1)/usr/lib
135
+	$(CP) \
136
+		$(PKG_INSTALL_DIR)/usr/lib/libexslt.so.* \
137
+		$(1)/usr/lib/
138
+endef
139
+
140
+define Package/xsltproc/install
141
+	$(INSTALL_DIR) $(1)/usr/bin
142
+	$(INSTALL_BIN) \
143
+		$(PKG_INSTALL_DIR)/usr/bin/xsltproc \
144
+		$(1)/usr/bin/
145
+endef
146
+
147
+$(eval $(call BuildPackage,libxslt))
148
+$(eval $(call BuildPackage,libexslt))
149
+$(eval $(call BuildPackage,xsltproc))