Browse Source

bash: Refresh patches

Signed-off-by: Marcel Denia <naoir@gmx.net>
Marcel Denia 10 years ago
parent
commit
f73ee0d75d

+ 2
- 2
utils/bash/patches/001-compile-fix.patch View File

@@ -1,6 +1,6 @@
1 1
 --- a/execute_cmd.c
2 2
 +++ b/execute_cmd.c
3
-@@ -2202,7 +2202,11 @@ execute_pipeline (command, asynchronous,
3
+@@ -2369,7 +2369,11 @@ execute_pipeline (command, asynchronous,
4 4
    /* If the `lastpipe' option is set with shopt, and job control is not
5 5
       enabled, execute the last element of non-async pipelines in the
6 6
       current shell environment. */
@@ -11,5 +11,5 @@
11 11
 +#endif
12 12
 +               asynchronous == 0 && pipe_out == NO_PIPE && prev > 0)
13 13
      {
14
-       lstdin = move_to_high_fd (0, 0, 255);
14
+       lstdin = move_to_high_fd (0, 1, -1);
15 15
        if (lstdin > 0)

+ 4
- 4
utils/bash/patches/002-force-internal-readline.patch View File

@@ -1,6 +1,6 @@
1 1
 --- a/configure
2 2
 +++ b/configure
3
-@@ -5748,8 +5748,7 @@ _ACEOF
3
+@@ -5430,8 +5430,7 @@ if test $opt_readline = yes; then
4 4
  		# static version specified as -llibname to override the
5 5
  		# dynamic version
6 6
  		case "${host_os}" in
@@ -10,9 +10,9 @@
10 10
  		esac
11 11
  	fi
12 12
  else
13
---- a/configure.in
14
-+++ b/configure.in
15
-@@ -540,8 +540,7 @@ if test $opt_readline = yes; then
13
+--- a/configure.ac
14
++++ b/configure.ac
15
+@@ -578,8 +578,7 @@ if test $opt_readline = yes; then
16 16
  		# static version specified as -llibname to override the
17 17
  		# dynamic version
18 18
  		case "${host_os}" in

+ 3
- 4
utils/bash/patches/129-no_doc.patch View File

@@ -1,7 +1,6 @@
1
-diff -urN bash-4.2/Makefile.in bash-4.2.new/Makefile.in
2
---- bash-4.2/Makefile.in	2010-12-01 01:22:42.000000000 +0100
3
-+++ bash-4.2.new/Makefile.in	2012-07-30 16:24:01.325057998 +0200
4
-@@ -724,10 +724,8 @@
1
+--- a/Makefile.in
2
++++ b/Makefile.in
3
+@@ -741,10 +741,8 @@ reconfig: force
5 4
  #	$(MAKE) -f $(srcdir)/Makefile $(MFLAGS) srcdir=$(srcdir)
6 5
  
7 6
  doc documentation:  force