Переглянути джерело

libxml2: prevent host compile to overwrite xml2-config (closes #2566)

Host compilation overwrites "$(STAGING_DIR)/host/bin/xml2-config
with an unpatched variant. So apply the same sed expression before
installing the file during host install.

Thanks to @zyxmon for spotting this.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Michael Heimpold 8 роки тому
джерело
коміт
f75da5729b
1 змінених файлів з 5 додано та 0 видалено
  1. 5
    0
      libs/libxml2/Makefile

+ 5
- 0
libs/libxml2/Makefile Переглянути файл

@@ -130,5 +130,10 @@ define Package/libxml2/install
130 130
 	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libxml2.so* $(1)/usr/lib/
131 131
 endef
132 132
 
133
+define Host/Install
134
+	$(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' $(HOST_BUILD_DIR)/xml2-config
135
+	$(call Host/Install/Default)
136
+endef
137
+
133 138
 $(eval $(call HostBuild))
134 139
 $(eval $(call BuildPackage,libxml2))