Browse Source

gnutls: Allow enabling smart card support as option.

Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Nikos Mavrogiannopoulos 10 years ago
parent
commit
f87135adb3
2 changed files with 16 additions and 3 deletions
  1. 5
    0
      libs/gnutls/Config.in
  2. 11
    3
      libs/gnutls/Makefile

+ 5
- 0
libs/gnutls/Config.in View File

@@ -31,6 +31,11 @@ config GNUTLS_PSK
31 31
 config GNUTLS_ANON
32 32
 	bool "enable anonymous authentication support"
33 33
 
34
+config GNUTLS_PKCS11
35
+	bool "enable smart card (PKCS11) support"
36
+	select GNUTLS_EXT_LIBTASN1
37
+	default n
38
+
34 39
 config GNUTLS_EXT_LIBTASN1
35 40
 	bool "use external libtasn1"
36 41
 	default n

+ 11
- 3
libs/gnutls/Makefile View File

@@ -75,7 +75,7 @@ endef
75 75
 define Package/libgnutls
76 76
 $(call Package/gnutls/Default)
77 77
   TITLE+= (library)
78
-  DEPENDS+= +libnettle +!LIBNETTLE_MINI:libgmp +GNUTLS_EXT_LIBTASN1:libtasn1
78
+  DEPENDS+= +libnettle +!LIBNETTLE_MINI:libgmp +GNUTLS_EXT_LIBTASN1:libtasn1 +GNUTLS_PKCS11:p11-kit
79 79
 endef
80 80
 
81 81
 define Package/libgnutls/description
@@ -106,13 +106,16 @@ CONFIGURE_ARGS+= \
106 106
 	--disable-doc \
107 107
 	--disable-tests \
108 108
 	--disable-rsa-export \
109
-	--disable-crywrap \
110
-	--without-p11-kit
109
+	--disable-crywrap
111 110
 
112 111
 ifneq ($(CONFIG_GNUTLS_EXT_LIBTASN1),y)
113 112
 CONFIGURE_ARGS += --with-included-libtasn1
114 113
 endif
115 114
 
115
+ifneq ($(CONFIG_GNUTLS_PKCS11),y)
116
+CONFIGURE_ARGS += --without-p11-kit
117
+endif
118
+
116 119
 ifeq ($(CONFIG_LIBNETTLE_MINI),y)
117 120
 CONFIGURE_ARGS += --with-nettle-mini
118 121
 endif
@@ -209,6 +212,11 @@ ifeq ($(CONFIG_GNUTLS_PSK),y)
209 212
 		$(PKG_INSTALL_DIR)/usr/bin/psktool \
210 213
 		$(1)/usr/bin/
211 214
 endif
215
+ifeq ($(CONFIG_GNUTLS_PKCS11),y)
216
+	$(CP) \
217
+		$(PKG_INSTALL_DIR)/usr/bin/p11tool \
218
+		$(1)/usr/bin/
219
+endif
212 220
 endef
213 221
 
214 222