Browse Source

freeradius-client: added library

Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Nikos Mavrogiannopoulos 9 years ago
parent
commit
f97dd00458
1 changed files with 55 additions and 0 deletions
  1. 55
    0
      libs/freeradius-client/Makefile

+ 55
- 0
libs/freeradius-client/Makefile View File

@@ -0,0 +1,55 @@
1
+#
2
+# Copyright (C) 2011 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=freeradius-client
11
+PKG_VERSION:=1.1.7
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=freeradius-client-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=ftp://ftp.freeradius.org/pub/freeradius/
16
+PKG_MD5SUM:=43b4d21715b613dc4fe8ef128467fe78
17
+
18
+PKG_INSTALL:=1
19
+
20
+include $(INCLUDE_DIR)/package.mk
21
+
22
+define Package/freeradius-client
23
+  SECTION:=libs
24
+  CATEGORY:=Libraries
25
+  TITLE:=A library for radius clients
26
+  URL:=http://freeradius.org/freeradius-client/
27
+  MAINTAINER:=Nikos Mavrogiannopoulos <nmav@gnutls.org>
28
+endef
29
+
30
+define Package/freeradius-client/decription
31
+  FreeRADIUS Client is a framework and library for writing RADIUS
32
+  Clients. The library lets you develop a RADIUS-aware application
33
+  in less than 50 lines of C code. It is highly portable and runs on
34
+  Linux, many BSD variants and Solaris.
35
+endef
36
+
37
+define Build/InstallDev
38
+	$(INSTALL_DIR) $(1)/usr/include
39
+	$(CP) \
40
+		$(PKG_INSTALL_DIR)/usr/include/freeradius-client.h \
41
+		$(1)/usr/include/
42
+	$(INSTALL_DIR) $(1)/usr/lib
43
+	$(CP) \
44
+		$(PKG_INSTALL_DIR)/usr/lib/libfreeradius-client.{a,so*} \
45
+		$(1)/usr/lib/
46
+endef
47
+
48
+define Package/freeradius-client/install
49
+	$(INSTALL_DIR) $(1)/usr/lib
50
+	$(CP) \
51
+		$(PKG_INSTALL_DIR)/usr/lib/libfreeradius-client.so.* \
52
+		$(1)/usr/lib/
53
+endef
54
+
55
+$(eval $(call BuildPackage,freeradius-client))