Browse Source

minicom: Import 2.3 from packages and update to 2.7.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Álvaro Fernández Rojas 10 years ago
parent
commit
fa7fae7495
2 changed files with 57 additions and 0 deletions
  1. 45
    0
      utils/minicom/Makefile
  2. 12
    0
      utils/minicom/patches/100-fix_iconv_include.patch

+ 45
- 0
utils/minicom/Makefile View File

@@ -0,0 +1,45 @@
1
+#
2
+# Copyright (C) 2006-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=minicom
11
+PKG_VERSION:=2.7
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=https://alioth.debian.org/frs/download.php/file/3977/
16
+PKG_MD5SUM:=7044ca3e291268c33294f171d426dc2d
17
+PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
18
+
19
+PKG_LICENSE:=GPL-2.0
20
+PKG_LICENSE_FILES:=COPYING
21
+
22
+PKG_FIXUP:=autoreconf
23
+
24
+include $(INCLUDE_DIR)/package.mk
25
+
26
+define Package/minicom
27
+  SECTION:=utils
28
+  CATEGORY:=Utilities
29
+  DEPENDS:=+libncurses
30
+  TITLE:=Terminal emulation program
31
+  URL:=http://alioth.debian.org/projects/minicom/
32
+  SUBMENU:=Terminal
33
+endef
34
+
35
+define Package/minicom/conffiles
36
+/etc/minirc.dfl
37
+endef
38
+
39
+define Package/minicom/install
40
+	$(INSTALL_DIR) $(1)/usr/sbin
41
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/sbin/
42
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ascii-xfr $(1)/usr/sbin/
43
+endef
44
+
45
+$(eval $(call BuildPackage,minicom))

+ 12
- 0
utils/minicom/patches/100-fix_iconv_include.patch View File

@@ -0,0 +1,12 @@
1
+--- a/src/minicom.c
2
++++ b/src/minicom.c
3
+@@ -31,7 +31,9 @@
4
+ #include <getopt.h>
5
+ #include <wchar.h>
6
+ #include <wctype.h>
7
++#ifdef HAVE_ICONV
8
+ #include <iconv.h>
9
++#endif
10
+ #include <limits.h>
11
+ 
12
+ #define EXTERN