Browse Source

Merge pull request #784 from commodo/python-fix-debian

python: add patch to remove Debian/Ubuntu multiarch support
Steven Barth 10 years ago
parent
commit
fa8a8f91e6
1 changed files with 12 additions and 0 deletions
  1. 12
    0
      lang/python/patches/160-remove-debian-multiarch-support.patch

+ 12
- 0
lang/python/patches/160-remove-debian-multiarch-support.patch View File

@@ -0,0 +1,12 @@
1
+diff --git a/setup.py b/setup.py
2
+index 7868b7b..9ae0ef2 100644
3
+--- a/setup.py
4
++++ b/setup.py
5
+@@ -444,7 +444,6 @@ class PyBuildExt(build_ext):
6
+             add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
7
+         if cross_compiling:
8
+             self.add_gcc_paths()
9
+-        self.add_multiarch_paths()
10
+ 
11
+         # Add paths specified in the environment variables LDFLAGS and
12
+         # CPPFLAGS for header and library files.