Procházet zdrojové kódy

add tracertools package

tracertools are an early hack to make use of the monitor port of
the Tracer MPPT solar charge controller family.

Currently status info can be acquired from the controller and
formatted into a bunch of useful output formats.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Daniel Golle před 10 roky
rodič
revize
fb55936a52
1 změnil soubory, kde provedl 44 přidání a 0 odebrání
  1. 44
    0
      utils/tracertools/Makefile

+ 44
- 0
utils/tracertools/Makefile Zobrazit soubor

@@ -0,0 +1,44 @@
1
+#
2
+# Copyright (C) 2007-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=tracertools
11
+PKG_VERSION:=0.1
12
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
13
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
14
+
15
+PKG_LICENSE:=GPL-3.0
16
+
17
+PKG_SOURCE_PROTO:=git
18
+PKG_SOURCE_URL:=https://gitorious.org/tracertools/tracertools.git
19
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
20
+PKG_SOURCE_VERSION:=701691a5e206dca361f5b5e5bd2f508dd5b160cd
21
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
22
+
23
+PKG_INSTALL:=1
24
+
25
+include $(INCLUDE_DIR)/package.mk
26
+
27
+define Package/tracertools
28
+  SECTION:=utils
29
+  CATEGORY:=Utilities
30
+  TITLE:=Tracer probing/fuzzing
31
+endef
32
+
33
+define Package/tracertools/description
34
+	Tools for the Tracer MPPT solar charge controller.
35
+endef
36
+
37
+define Package/tracertools/install
38
+	$(INSTALL_DIR) $(1)/usr/bin
39
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/reqdata $(1)/usr/bin/
40
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/parsereply $(1)/usr/bin/
41
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/fuzzreply $(1)/usr/bin/
42
+endef
43
+
44
+$(eval $(call BuildPackage,tracertools))