|
@@ -0,0 +1,29 @@
|
|
1
|
+diff -Nru alpine-2.20-orig/configure alpine-2.20/configure
|
|
2
|
+--- alpine-2.20-orig/configure 2015-01-18 09:00:42.100645053 +0200
|
|
3
|
++++ alpine-2.20/configure 2015-01-25 12:01:11.831015443 +0200
|
|
4
|
+@@ -17643,10 +17643,8 @@
|
|
5
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking Openssl library version >= 1.0.1c" >&5
|
|
6
|
+ $as_echo_n "checking Openssl library version >= 1.0.1c... " >&6; }
|
|
7
|
+ if test "$cross_compiling" = yes; then :
|
|
8
|
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
|
|
9
|
+-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
|
10
|
+-as_fn_error $? "cannot run test program while cross compiling
|
|
11
|
+-See \`config.log' for more details" "$LINENO" 5; }
|
|
12
|
++ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: cross compiling: not checking" >&5
|
|
13
|
++$as_echo "$as_me: WARNING: cross compiling: not checking" >&2;}
|
|
14
|
+ else
|
|
15
|
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
|
16
|
+ /* end confdefs.h. */
|
|
17
|
+diff -Nru alpine-2.20-orig/configure.ac alpine-2.20/configure.ac
|
|
18
|
+--- alpine-2.20-orig/configure.ac 2015-01-18 08:38:08.893495949 +0200
|
|
19
|
++++ alpine-2.20/configure.ac 2015-01-25 12:01:02.773015236 +0200
|
|
20
|
+@@ -1370,7 +1370,8 @@
|
|
21
|
+ }
|
|
22
|
+ ]])],
|
|
23
|
+ [ AC_MSG_RESULT(yes) ],
|
|
24
|
+- [ alpine_SSLTYPE="none" ])
|
|
25
|
++ [ alpine_SSLTYPE="none" ],
|
|
26
|
++ [ AC_MSG_WARN([cross compiling: not checking])])
|
|
27
|
+
|
|
28
|
+ if test "x$alpine_SSLTYPE" = "xnone" ; then
|
|
29
|
+ AC_MSG_ERROR(Install openssl version >= 1.0.1c)
|