Browse Source

ruby: bump to 2.2.4

This release includes a security fix for Fiddle extension.

* CVE-2015-7551: Unsafe tainted string usage in Fiddle and DL

There are also some bugfixes.

In package, now LD_FLAGS is copied to DLD_FLAGS (used by ruby for libraries).
The missing values from LD_FLAGS cause build error when gcc does not implicitly
include staging/usr/lib.

Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Luiz Angelo Daros de Luca 9 years ago
parent
commit
fbd2b86dca
1 changed files with 9 additions and 2 deletions
  1. 9
    2
      lang/ruby/Makefile

+ 9
- 2
lang/ruby/Makefile View File

@@ -10,14 +10,14 @@
10 10
 include $(TOPDIR)/rules.mk
11 11
 
12 12
 PKG_NAME:=ruby
13
-PKG_VERSION:=2.2.3
13
+PKG_VERSION:=2.2.4
14 14
 PKG_RELEASE:=1
15 15
 
16 16
 PKG_LIBVER:=2.2
17 17
 
18 18
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
19 19
 PKG_SOURCE_URL:=http://cache.ruby-lang.org/pub/ruby/$(PKG_LIBVER)/
20
-PKG_MD5SUM:=f49a734729a71774d4a94a9a603114b2
20
+PKG_MD5SUM:=c3d65f6d2ebe90dda81a37885ea244f5
21 21
 PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
22 22
 PKG_LICENSE:=BSD-2-Clause
23 23
 PKG_LICENSE_FILES:=COPYING
@@ -833,6 +833,13 @@ endif
833 833
 
834 834
 TARGET_LDFLAGS += -L$(PKG_BUILD_DIR)
835 835
 
836
+# Ruby uses DLDFLAGS and not LDFLAGS for libraries. LDFLAGS is only for execs.
837
+# However, DLDFLAGS from configure is not passed to Makefile when target is linux.
838
+# XLDFLAGS is used by both libraries and execs. This is somehow brute force but
839
+# if will fix when some LD_FLAGS is needef for libraries. As side effect, it will
840
+# duplicate ld args for binaries.
841
+CONFIGURE_VARS += XLDFLAGS="$(TARGET_LDFLAGS)"
842
+
836 843
 MAKE_FLAGS += \
837 844
 	DESTDIR="$(PKG_INSTALL_DIR)" \
838 845
 	SHELL="/bin/bash"