Przeglądaj źródła

flashrom: fix build with musl

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Álvaro Fernández Rojas 9 lat temu
rodzic
commit
fc959cf5b8

+ 1
- 1
utils/flashrom/Makefile Wyświetl plik

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=flashrom
11 11
 PKG_VERSION:=0.9.8
12
-PKG_RELEASE:=2
12
+PKG_RELEASE:=3
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15 15
 PKG_SOURCE_URL:=http://download.flashrom.org/releases

+ 12
- 0
utils/flashrom/patches/0002-fix-musl-compatibility.patch Wyświetl plik

@@ -0,0 +1,12 @@
1
+diff -uprN a/linux_spi.c b/linux_spi.c
2
+--- a/linux_spi.c	2015-06-17 20:50:36.492963100 +0200
3
++++ b/linux_spi.c	2015-06-17 20:50:00.444860800 +0200
4
+@@ -22,7 +22,7 @@
5
+ #include <stdio.h>
6
+ #include <string.h>
7
+ #include <stdlib.h>
8
+-#include <sys/fcntl.h>
9
++#include <fcntl.h>
10
+ #include <errno.h>
11
+ #include <ctype.h>
12
+ #include <unistd.h>