|
@@ -0,0 +1,35 @@
|
|
1
|
+From 26f8177f799f3cf781ed89cb28f771da7ef22421 Mon Sep 17 00:00:00 2001
|
|
2
|
+From: =?UTF-8?q?=C3=81lvaro=20Fern=C3=A1ndez=20Rojas?= <noltari@gmail.com>
|
|
3
|
+Date: Thu, 5 Mar 2015 13:42:09 +0100
|
|
4
|
+Subject: [PATCH] fix build on Mac OS X
|
|
5
|
+MIME-Version: 1.0
|
|
6
|
+Content-Type: text/plain; charset=UTF-8
|
|
7
|
+Content-Transfer-Encoding: 8bit
|
|
8
|
+
|
|
9
|
+Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
|
|
10
|
+---
|
|
11
|
+ chipmunk/Makefile | 5 ++++-
|
|
12
|
+ 1 file changed, 4 insertions(+), 1 deletion(-)
|
|
13
|
+
|
|
14
|
+diff --git a/chipmunk/Makefile b/chipmunk/Makefile
|
|
15
|
+index e402128..fd41dbe 100644
|
|
16
|
+--- a/chipmunk/Makefile
|
|
17
|
++++ b/chipmunk/Makefile
|
|
18
|
+@@ -32,10 +32,13 @@ DEBUG_ON := -g
|
|
19
|
+ ALL_CFLAGS = -W -Wall -Werror --pedantic $(CFLAGS)
|
|
20
|
+
|
|
21
|
+ SYSTEM=$(shell uname 2>/dev/null)
|
|
22
|
+-ifneq (,$(filter $(SYSTEM),FreeBSD Darwin))
|
|
23
|
++ifneq (,$(filter $(SYSTEM),FreeBSD))
|
|
24
|
+ MAKE := gmake
|
|
25
|
+ GZIP := /usr/bin/gzip
|
|
26
|
+ endif
|
|
27
|
++ifneq (,$(filter $(SYSTEM),Darwin))
|
|
28
|
++GZIP := /usr/bin/gzip
|
|
29
|
++endif
|
|
30
|
+
|
|
31
|
+ BUILDFILE = BUILD
|
|
32
|
+ BUILDNO := `cat $(BUILDFILE)`
|
|
33
|
+--
|
|
34
|
+2.3.1
|
|
35
|
+
|