Browse Source

udpxy: fix build on OS X and clean up Makefile

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Álvaro Fernández Rojas 10 years ago
parent
commit
fd62435cd4
2 changed files with 40 additions and 5 deletions
  1. 5
    5
      net/udpxy/Makefile
  2. 35
    0
      net/udpxy/patches/0001-fix-build-on-Mac-OS-X.patch

+ 5
- 5
net/udpxy/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2006-2014 OpenWrt.org
2
+# Copyright (C) 2006-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -8,14 +8,14 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=udpxy
11
-PKG_VERSION:=2014-10-27
12
-PKG_RELEASE:=$(PKG_SOURCE_VERSION)
11
+PKG_SOURCE_VERSION:=c045a1e855a8033c5d70ab3e42271ba5636eb520
12
+PKG_VERSION:=2014-10-27-$(PKG_SOURCE_VERSION)
13
+PKG_RELEASE:=2
13 14
 
14 15
 PKG_SOURCE_PROTO:=git
15 16
 PKG_SOURCE_URL:=git://github.com/pcherenkov/udpxy.git
16 17
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
17
-PKG_SOURCE_VERSION:=c045a1e855a8033c5d70ab3e42271ba5636eb520
18
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
18
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
19 19
 PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
20 20
 
21 21
 PKG_LICENSE:=GPL-3.0

+ 35
- 0
net/udpxy/patches/0001-fix-build-on-Mac-OS-X.patch View File

@@ -0,0 +1,35 @@
1
+From 26f8177f799f3cf781ed89cb28f771da7ef22421 Mon Sep 17 00:00:00 2001
2
+From: =?UTF-8?q?=C3=81lvaro=20Fern=C3=A1ndez=20Rojas?= <noltari@gmail.com>
3
+Date: Thu, 5 Mar 2015 13:42:09 +0100
4
+Subject: [PATCH] fix build on Mac OS X
5
+MIME-Version: 1.0
6
+Content-Type: text/plain; charset=UTF-8
7
+Content-Transfer-Encoding: 8bit
8
+
9
+Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
10
+---
11
+ chipmunk/Makefile | 5 ++++-
12
+ 1 file changed, 4 insertions(+), 1 deletion(-)
13
+
14
+diff --git a/chipmunk/Makefile b/chipmunk/Makefile
15
+index e402128..fd41dbe 100644
16
+--- a/chipmunk/Makefile
17
++++ b/chipmunk/Makefile
18
+@@ -32,10 +32,13 @@ DEBUG_ON := -g
19
+ ALL_CFLAGS = -W -Wall -Werror --pedantic $(CFLAGS)
20
+ 
21
+ SYSTEM=$(shell uname 2>/dev/null)
22
+-ifneq (,$(filter $(SYSTEM),FreeBSD Darwin))
23
++ifneq (,$(filter $(SYSTEM),FreeBSD))
24
+ MAKE := gmake
25
+ GZIP := /usr/bin/gzip
26
+ endif
27
++ifneq (,$(filter $(SYSTEM),Darwin))
28
++GZIP := /usr/bin/gzip
29
++endif
30
+ 
31
+ BUILDFILE = BUILD
32
+ BUILDNO := `cat $(BUILDFILE)`
33
+-- 
34
+2.3.1
35
+