Browse Source

Merge pull request #384 from arfett/master

mwan3-luci: update to 1.3-4
sbyx 10 years ago
parent
commit
fdcde6150c

+ 1
- 1
net/mwan3-luci/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=luci-app-mwan3
11 11
 PKG_VERSION:=1.3
12
-PKG_RELEASE:=2
12
+PKG_RELEASE:=4
13 13
 PKG_MAINTAINER:=Aedan Renner <chipdankly@gmail.com>
14 14
 PKG_LICENSE:=GPLv2
15 15
 

+ 1
- 0
net/mwan3-luci/files/etc/hotplug.d/iface/16-mwan3custombak View File

@@ -7,6 +7,7 @@ send_alert()
7 7
 {
8 8
 	# variable "$1" stores the mwan3 status information
9 9
 	# insert your code here to send the contents of "$1"
10
+	echo "$1"
10 11
 }
11 12
 
12 13
 gather_event_info()

+ 5
- 5
net/mwan3-luci/files/usr/lib/lua/luci/model/cbi/mwan3/mwan3_policy.lua View File

@@ -72,12 +72,12 @@ last_resort = mwan_policy:option(DummyValue, "last_resort", translate("Last reso
72 72
 	last_resort.rawhtml = true
73 73
 	function last_resort.cfgvalue(self, s)
74 74
 		local str = self.map:get(s, "last_resort")
75
-		if str == "unreachable" or str == "" or str == null then
76
-			return "unreachable (reject)"
77
-		elseif str == "blackhole" then
75
+		if str == "blackhole" then
78 76
 			return "blackhole (drop)"
79
-		elseif str == "main" then
80
-			return "main (use main routing table)"
77
+		elseif str == "default" then
78
+			return "default (use main routing table)"
79
+		else
80
+			return "unreachable (reject)"
81 81
 		end
82 82
 	end
83 83
 

+ 1
- 1
net/mwan3-luci/files/usr/lib/lua/luci/model/cbi/mwan3/mwan3_policyconfig.lua View File

@@ -50,7 +50,7 @@ last_resort = mwan_policy:option(ListValue, "last_resort", translate("Last resor
50 50
 	last_resort.default = "unreachable"
51 51
 	last_resort:value("unreachable", translate("unreachable (reject)"))
52 52
 	last_resort:value("blackhole", translate("blackhole (drop)"))
53
-	last_resort:value("main", translate("main (use main routing table)"))
53
+	last_resort:value("default", translate("default (use main routing table)"))
54 54
 
55 55
 
56 56
 -- ------ currently configured members ------ --

+ 3
- 2
net/mwan3-luci/files/usr/lib/lua/luci/model/cbi/mwan3/mwan3_ruleconfig.lua View File

@@ -83,8 +83,9 @@ proto = mwan_rule:option(Value, "proto", translate("Protocol"),
83 83
 
84 84
 use_policy = mwan_rule:option(Value, "use_policy", translate("Policy assigned"))
85 85
 	cbi_add_policy(use_policy)
86
-	use_policy:value("unreachable")
87
-	use_policy:value("default")
86
+	use_policy:value("unreachable", translate("unreachable (reject)"))
87
+	use_policy:value("blackhole", translate("blackhole (drop)"))
88
+	use_policy:value("default", translate("default (use main routing table)"))
88 89
 
89 90
 
90 91
 -- ------ currently configured policies ------ --