Kaynağa Gözat

php5: update to 5.6.6

Signed-off-by: W. Michael Petullo <mike@flyn.org>
W. Michael Petullo 10 yıl önce
ebeveyn
işleme
fec32996ff

+ 3
- 3
lang/php5/Makefile Dosyayı Görüntüle

@@ -8,7 +8,7 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=php
11
-PKG_VERSION:=5.4.38
11
+PKG_VERSION:=5.6.6
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
@@ -18,9 +18,9 @@ PKG_LICENSE_FILES:=LICENSE
18 18
 
19 19
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
20 20
 PKG_SOURCE_URL:=http://www.php.net/distributions/
21
-PKG_MD5SUM:=2bf5007ba4bd012f9895c1b441dd4f50
21
+PKG_MD5SUM:=b198117ee1d44c8143e030cee15f1b52
22 22
 
23
-PKG_FIXUP:=libtool no-autoreconf
23
+PKG_FIXUP:=libtool autoreconf
24 24
 PKG_BUILD_PARALLEL:=1
25 25
 PKG_USE_MIPS16:=0
26 26
 

+ 51
- 3
lang/php5/patches/950-Fix-dl-cross-compiling-issue.patch Dosyayı Görüntüle

@@ -1,6 +1,7 @@
1
---- a/configure.in
2
-+++ b/configure.in
3
-@@ -453,7 +453,10 @@ PHP_CHECK_FUNC(gethostname, nsl)
1
+diff -u --recursive php-5.6.6-vanilla/configure.in php-5.6.6/configure.in
2
+--- php-5.6.6-vanilla/configure.in	2015-02-26 22:10:51.865487530 -0500
3
++++ php-5.6.6/configure.in	2015-02-26 22:29:59.043102135 -0500
4
+@@ -453,7 +453,10 @@
4 5
  PHP_CHECK_FUNC(gethostbyaddr, nsl)
5 6
  PHP_CHECK_FUNC(yp_get_default_domain, nsl)
6 7
  
@@ -12,3 +13,50 @@
12 13
  if test "$ac_cv_func_dlopen" = "yes"; then
13 14
    AC_DEFINE(HAVE_LIBDL, 1, [ ])
14 15
  fi
16
+diff -u --recursive php-5.6.6-vanilla/ext/fileinfo/config.m4 php-5.6.6/ext/fileinfo/config.m4
17
+--- php-5.6.6-vanilla/ext/fileinfo/config.m4	2015-02-26 22:10:51.639487135 -0500
18
++++ php-5.6.6/ext/fileinfo/config.m4	2015-02-26 22:22:47.645609128 -0500
19
+@@ -46,6 +46,10 @@
20
+     AC_MSG_RESULT(no)
21
+     AC_MSG_NOTICE(using libmagic strcasestr implementation)
22
+     libmagic_sources="$libmagic_sources libmagic/strcasestr.c"
23
++  ],[
24
++    dnl cross-compiling; assume not present
25
++    AC_MSG_NOTICE(using libmagic strcasestr implementation)
26
++    libmagic_sources="$libmagic_sources libmagic/strcasestr.c"
27
+   ])
28
+ 
29
+   PHP_NEW_EXTENSION(fileinfo, fileinfo.c $libmagic_sources, $ext_shared,,-I@ext_srcdir@/libmagic)
30
+diff -u --recursive php-5.6.6-vanilla/ext/opcache/config.m4 php-5.6.6/ext/opcache/config.m4
31
+--- php-5.6.6-vanilla/ext/opcache/config.m4	2015-02-26 22:10:51.790487399 -0500
32
++++ php-5.6.6/ext/opcache/config.m4	2015-02-26 22:34:19.240414394 -0500
33
+@@ -341,7 +341,14 @@
34
+ 	flock_type=linux
35
+     AC_DEFINE([HAVE_FLOCK_LINUX], [], [Struct flock is Linux-type])
36
+     AC_MSG_RESULT("yes")
37
+-], AC_MSG_RESULT("no") )
38
++], [
39
++    AC_MSG_RESULT("no")
40
++], [
41
++    dnl cross-compiling; assume Linux
42
++	flock_type=linux
43
++    AC_DEFINE([HAVE_FLOCK_LINUX], [], [Struct flock is Linux-type])
44
++    AC_MSG_RESULT("yes")
45
++])
46
+ 
47
+ AC_MSG_CHECKING("whether flock struct is BSD ordered")
48
+ AC_TRY_RUN([
49
+@@ -357,7 +364,12 @@
50
+ 	flock_type=bsd
51
+     AC_DEFINE([HAVE_FLOCK_BSD], [], [Struct flock is BSD-type]) 
52
+     AC_MSG_RESULT("yes")
53
+-], AC_MSG_RESULT("no") )
54
++], [
55
++    AC_MSG_RESULT("no")
56
++], [
57
++    dnl cross-compiling; assume Linux
58
++    AC_MSG_RESULT("no")
59
++])
60
+ 
61
+ if test "$flock_type" == "unknown"; then
62
+ 	AC_MSG_ERROR([Don't know how to define struct flock on this system[,] set --enable-opcache=no])