Browse Source

Merge pull request #2530 from dangowrt/update-postgresql-to-9-5-1

postgresql: update source to 9.5.1 and refresh patches
Jo-Philipp Wich 8 years ago
parent
commit
ff0f689f97

+ 5
- 5
libs/postgresql/Makefile View File

@@ -8,7 +8,7 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=postgresql
11
-PKG_VERSION:=9.4.4
11
+PKG_VERSION:=9.5.1
12 12
 PKG_RELEASE:=1
13 13
 PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
14 14
 PKG_LICENSE:=PostgreSQL
@@ -18,7 +18,7 @@ PKG_SOURCE_URL:=\
18 18
 	http://ftp9.us.postgresql.org/pub/mirrors/postgresql/source/v$(PKG_VERSION) \
19 19
 	http://ftp.be.postgresql.org/postgresql/source/v$(PKG_VERSION) \
20 20
 	ftp://ftp-archives.postgresql.org/pub/source/v$(PKG_VERSION)
21
-PKG_MD5SUM:=1fe952c44ed26d7e6a335cf991a9c1c6
21
+PKG_MD5SUM:=11e037afaa4bd0c90bb3c3d955e2b401
22 22
 PKG_BUILD_PARALLEL:=1
23 23
 PKG_USE_MIPS16:=0
24 24
 PKG_FIXUP:=autoreconf
@@ -29,7 +29,7 @@ include $(INCLUDE_DIR)/package.mk
29 29
 define Package/libpq
30 30
   SECTION:=libs
31 31
   CATEGORY:=Libraries
32
-  DEPENDS:=+zlib +libreadline +libpthread +libncurses +shadow-utils +shadow-su
32
+  DEPENDS:=+zlib +libreadline +libpthread +libncurses
33 33
   TITLE:=PostgreSQL client library
34 34
   URL:=http://www.postgresql.org/
35 35
   SUBMENU:=database
@@ -42,7 +42,7 @@ endef
42 42
 define Package/pgsql-cli
43 43
   SECTION:=utils
44 44
   CATEGORY:=Utilities
45
-  DEPENDS:=+libpq +USE_UCLIBC:librt
45
+  DEPENDS:=+libpq +USE_UCLIBC:librt +shadow-utils +shadow-su
46 46
   TITLE:=Command Line Interface (CLI) to PostgreSQL databases
47 47
   URL:=http://www.postgresql.org/
48 48
   SUBMENU:=database
@@ -116,7 +116,7 @@ define Build/Configure
116 116
 			--enable-depend \
117 117
 			--with-system-timezone=/tmp \
118 118
 	);
119
-	$(MAKE) -C $(PKG_BUILD_DIR)/src/interfaces/ecpg/preproc CC="$(HOSTCC)" CFLAGS+="-I../../libpq"
119
+	$(MAKE) -C $(PKG_BUILD_DIR)/src/interfaces/ecpg/preproc CC="$(HOSTCC)"
120 120
 	mv $(PKG_BUILD_DIR)/src/interfaces/ecpg/preproc/ecpg \
121 121
 		$(PKG_BUILD_DIR)/src/interfaces/ecpg/preproc/ecpg.host
122 122
 	$(MAKE) -C $(PKG_BUILD_DIR)/src/timezone CC="$(HOSTCC)"

+ 1
- 1
libs/postgresql/patches/001-configure_fixes.patch View File

@@ -2,7 +2,7 @@
2 2
 +++ b/configure.in
3 3
 @@ -25,7 +25,7 @@ recommended.  You can remove the check f
4 4
  your responsibility whether the result works or not.])])
5
- AC_COPYRIGHT([Copyright (c) 1996-2014, PostgreSQL Global Development Group])
5
+ AC_COPYRIGHT([Copyright (c) 1996-2015, PostgreSQL Global Development Group])
6 6
  AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
7 7
 -AC_CONFIG_AUX_DIR(config)
8 8
 +AC_CONFIG_AUX_DIR([config])

+ 2
- 2
libs/postgresql/patches/200-ranlib.patch View File

@@ -1,8 +1,8 @@
1 1
 --- a/src/port/Makefile
2 2
 +++ b/src/port/Makefile
3
-@@ -52,6 +52,7 @@ uninstall:
4
- 
3
+@@ -53,6 +53,7 @@ uninstall:
5 4
  libpgport.a: $(OBJS)
5
+ 	rm -f $@
6 6
  	$(AR) $(AROPT) $@ $^
7 7
 +	$(RANLIB) libpgport.a
8 8
  

+ 2
- 2
libs/postgresql/patches/800-busybox-default-pager.patch View File

@@ -1,8 +1,8 @@
1 1
 --- a/src/bin/psql/print.h
2 2
 +++ b/src/bin/psql/print.h
3
-@@ -179,10 +179,6 @@ extern void printQuery(const PGresult *r
4
- extern void setDecimalLocale(void);
3
+@@ -197,10 +197,6 @@ extern void setDecimalLocale(void);
5 4
  extern const printTextFormat *get_line_style(const printTableOpt *opt);
5
+ extern void refresh_utf8format(const printTableOpt *opt);
6 6
  
7 7
 -#ifndef __CYGWIN__
8 8
 -#define DEFAULT_PAGER "more"