--- a/configure.in
+++ b/configure.in
@@ -11,14 +11,6 @@ AM_INIT_AUTOMAKE(snort,2.9.7.2)
 NO_OPTIMIZE="no"
 ADD_WERROR="no"
 
-# Test for -Werror and sed it out for now since some of the auto tests,
-# for example AC_CHECK_LIB, will fail because of
-# warning: conflicting types for built-in function <func>
-if eval "echo $CFLAGS | grep -e -Werror"; then
-    CFLAGS=`echo $CFLAGS | sed -e "s/-Werror//g"`
-    ADD_WERROR="yes"
-fi
-
 # Disable annoying practice of recursively re-running the autotools
 AM_MAINTAINER_MODE
 AC_PROG_CC_STDC