|
@@ -1,21 +0,0 @@
|
1
|
|
-Abort on failed module build
|
2
|
|
-
|
3
|
|
-When building a Python module fails, the setup.py script currently
|
4
|
|
-doesn't exit with an error, and simply continues. This is not a really
|
5
|
|
-nice behavior, so this patch changes setup.py to abort with an error,
|
6
|
|
-so that the build issue is clearly noticeable.
|
7
|
|
-
|
8
|
|
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
9
|
|
-
|
10
|
|
-Index: b/setup.py
|
11
|
|
-===================================================================
|
12
|
|
---- a/setup.py
|
13
|
|
-+++ b/setup.py
|
14
|
|
-@@ -283,6 +283,7 @@
|
15
|
|
- print "Failed to build these modules:"
|
16
|
|
- print_three_column(failed)
|
17
|
|
- print
|
18
|
|
-+ sys.exit(1)
|
19
|
|
-
|
20
|
|
- def build_extension(self, ext):
|
21
|
|
-
|