Procházet zdrojové kódy

Merge pull request #1469 from jow-/squid-musl-compat

squid: fix musl compatibility
Luka Perkov před 9 roky
rodič
revize
0983670143
2 změnil soubory, kde provedl 16 přidání a 1 odebrání
  1. 1
    1
      net/squid/Makefile
  2. 15
    0
      net/squid/patches/200-musl-compat.patch

+ 1
- 1
net/squid/Makefile Zobrazit soubor

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=squid
11 11
 PKG_VERSION:=3.5.2
12
-PKG_RELEASE:=3
12
+PKG_RELEASE:=4
13 13
 
14 14
 PKG_LICENSE:=GPL-2.0
15 15
 PKG_MAINTAINER:=Luka Perkov <luka@openwrt.org>

+ 15
- 0
net/squid/patches/200-musl-compat.patch Zobrazit soubor

@@ -0,0 +1,15 @@
1
+--- a/lib/rfcnb/rfcnb-io.c
2
++++ b/lib/rfcnb/rfcnb-io.c
3
+@@ -36,11 +36,11 @@
4
+ #include "rfcnb/rfcnb-util.h"
5
+ #include "rfcnb/std-includes.h"
6
+ 
7
++#include <signal.h>
8
+ #if HAVE_STRING_H
9
+ #include <string.h>
10
+ #endif
11
+ #include <sys/uio.h>
12
+-#include <sys/signal.h>
13
+ 
14
+ int RFCNB_Timeout = 0;          /* Timeout in seconds ... */
15
+