Browse Source

rng-tools: upgrade to version 5

Edit init script to match current options.
Update copyright year.
Simplify download location.
Add myself as maintainer.

signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Hannu Nyman 10 years ago
parent
commit
0b85e7e0bf
2 changed files with 10 additions and 8 deletions
  1. 8
    6
      utils/rng-tools/Makefile
  2. 2
    2
      utils/rng-tools/files/rngd.init

+ 8
- 6
utils/rng-tools/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2011 OpenWrt.org
2
+# Copyright (C) 2011-2014 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -8,21 +8,23 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=rng-tools
11
-PKG_VERSION:=3
12
-PKG_RELEASE:=2
11
+PKG_VERSION:=5
12
+PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
-PKG_SOURCE_URL:=http://downloads.sourceforge.net/project/gkernel/rng-tools/3/
16
-PKG_MD5SUM:=fa305916ec101c85c0065aeceb81a38d
15
+PKG_SOURCE_URL:=@SF/gkernel/rng-tools/$(PKG_VERSION)/
16
+PKG_MD5SUM:=6726cdc6fae1f5122463f24ae980dd68
17
+PKG_MAINTAINER:=Hannu Nyman <hannu.nyman@iki.fi>
17 18
 
18 19
 PKG_FIXUP:=autoreconf
19 20
 
21
+PKG_BUILD_DEPENDS:=USE_UCLIBC:argp-standalone
22
+
20 23
 include $(INCLUDE_DIR)/package.mk
21 24
 
22 25
 define Package/rng-tools
23 26
   SECTION:=utils
24 27
   CATEGORY:=Utilities
25
-  DEPENDS:=+USE_UCLIBC:argp-standalone
26 28
   TITLE:=Daemon for adding entropy to kernel entropy pool
27 29
   URL:=http://sourceforge.net/projects/gkernel/
28 30
 endef

+ 2
- 2
utils/rng-tools/files/rngd.init View File

@@ -1,5 +1,5 @@
1 1
 #!/bin/sh /etc/rc.common
2
-# Copyright (C) 2011 OpenWrt.org
2
+# Copyright (C) 2011-2014 OpenWrt.org
3 3
 
4 4
 START=98
5 5
 
@@ -8,7 +8,7 @@ RNGD_AMOUNT=4000
8 8
 RNGD_DEVICE="/dev/urandom"
9 9
 
10 10
 start() {
11
-	service_start /sbin/rngd -r $RNGD_DEVICE -W $RNGD_AMOUNT -t $RNGD_INTERVAL
11
+	service_start /sbin/rngd -r $RNGD_DEVICE -W $RNGD_AMOUNT
12 12
 }
13 13
 
14 14
 stop() {