Browse Source

python-dns: update compile rule and add PyPackage rules

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Alexandru Ardelean 10 years ago
parent
commit
0bfec165fa
1 changed files with 5 additions and 5 deletions
  1. 5
    5
      lang/python-dns/Makefile

+ 5
- 5
lang/python-dns/Makefile View File

@@ -34,13 +34,13 @@ define Package/python-dns/description
34 34
 endef
35 35
 
36 36
 define Build/Compile
37
-	$(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
37
+	$(call Build/Compile/PyMod,,\
38
+		install --prefix="$(PKG_INSTALL_DIR)/usr" \
39
+	)
38 40
 endef
39 41
 
40
-define Package/python-dns/install
41
-	$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
42
-	$(CP) $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/dns/* \
43
-		$(1)$(PYTHON_PKG_DIR)
42
+define PyPackage/python-dns/filespec
43
++|/usr/lib/python$(PYTHON_VERSION)/site-packages
44 44
 endef
45 45
 
46 46
 $(eval $(call PyPackage,python-dns))