Przeglądaj źródła

openssh,ntpd: move USERID to the server only as the client utils don't need a user/group

Signed-off-by: Peter Wagner <tripolar@gmx.at>
Peter Wagner 10 lat temu
rodzic
commit
0d260899aa
2 zmienionych plików z 5 dodań i 3 usunięć
  1. 2
    1
      net/ntpd/Makefile
  2. 3
    2
      net/openssh/Makefile

+ 2
- 1
net/ntpd/Makefile Wyświetl plik

@@ -31,7 +31,6 @@ define Package/ntpd/Default
31 31
   MAINTAINER:=Peter Wagner <tripolar@gmx.at>
32 32
   URL:=http://www.ntp.org/
33 33
   DEPENDS:=+libcap
34
-  USERID:=ntp=123:ntp=123
35 34
 endef
36 35
 
37 36
 define Package/ntpd/Default/description
@@ -44,6 +43,7 @@ define Package/ntpd
44 43
 $(call Package/ntpd/Default)
45 44
   TITLE+= server
46 45
   VARIANT:=nossl
46
+  USERID:=ntp=123:ntp=123
47 47
 endef
48 48
 
49 49
 define Package/ntpd/description
@@ -57,6 +57,7 @@ $(call Package/ntpd/Default)
57 57
   TITLE+= server (with OpenSSL support)
58 58
   VARIANT:=ssl
59 59
   DEPENDS+= +libopenssl
60
+  USERID:=ntp=123:ntp=123
60 61
 endef
61 62
 
62 63
 define Package/ntpd-ssl/description

+ 3
- 2
net/openssh/Makefile Wyświetl plik

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=openssh
11 11
 PKG_VERSION:=6.6p1
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
@@ -35,7 +35,6 @@ define Package/openssh/Default
35 35
 	URL:=http://www.openssh.com/
36 36
 	SUBMENU:=SSH
37 37
 	VARIANT:=without-pam
38
-	USERID:=sshd=22:sshd=22
39 38
 endef
40 39
 
41 40
 define Package/openssh-moduli
@@ -84,6 +83,7 @@ define Package/openssh-server
84 83
 	$(call Package/openssh/Default)
85 84
 	DEPENDS+= +openssh-keygen
86 85
 	TITLE+= server
86
+	USERID:=sshd=22:sshd=22
87 87
 endef
88 88
 
89 89
 define Package/openssh-server/description
@@ -99,6 +99,7 @@ define Package/openssh-server-pam
99 99
 	DEPENDS+= +libpthread +openssh-keygen +libpam
100 100
 	TITLE+= server (with PAM support)
101 101
 	VARIANT:=with-pam
102
+	USERID:=sshd=22:sshd=22
102 103
 endef
103 104
 
104 105
 define Package/openssh-server-pam/description