Browse Source

ntfs-3g: Update to latest, add myself as maintainer, cleanup packages content

Signed-off-by: Ted Hess <thess@kitschensync.net>
Ted Hess 9 years ago
parent
commit
0e3fb59ba1
1 changed files with 25 additions and 9 deletions
  1. 25
    9
      utils/ntfs-3g/Makefile

+ 25
- 9
utils/ntfs-3g/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2007-2014 OpenWrt.org
2
+# Copyright (C) 2007-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -10,14 +10,16 @@ include $(TOPDIR)/rules.mk
10 10
 PKG_NAME:=ntfs-3g
11 11
 PKG_RELEASE:=1
12 12
 
13
-PKG_VERSION:=2014.2.15
13
+PKG_VERSION:=2015.3.14
14 14
 PKG_SOURCE:=$(PKG_NAME)_ntfsprogs-$(PKG_VERSION).tgz
15 15
 PKG_SOURCE_URL:=http://www.tuxera.com/opensource/
16
-PKG_MD5SUM:=f11d563816249d730a00498983485f3a
16
+PKG_MD5SUM:=8cd57768310e3b2be39b3191d808e241
17 17
 
18 18
 PKG_LICENSE:=GPL-2.0 LGPL-2.0
19 19
 PKG_LICENSE_FILES:=COPYING COPYING.LIB
20 20
 
21
+PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
22
+
21 23
 PKG_FIXUP:=autoreconf
22 24
 PKG_INSTALL:=1
23 25
 
@@ -35,7 +37,6 @@ define Package/ntfs-3g/common
35 37
   URL:=http://www.tuxera.com
36 38
   SUBMENU:=Filesystem
37 39
   TITLE:=Stable Read/Write NTFS Driver
38
-  MAINTAINER:=Bud <wrt_buddhay@gmx.net>
39 40
 endef
40 41
 
41 42
 define Package/ntfs-3g
@@ -88,22 +89,36 @@ endef
88 89
 
89 90
 define Package/ntfs-3g-utils
90 91
   $(call Package/ntfs-3g/common)
91
-  TITLE:=ntfs-3g utilities (ntfs-3g.secaudit, ntfs-3g.usermap)
92
+  TITLE:=ntfs-3g utilities (extra)
92 93
   DEPENDS+= +ntfs-3g
93 94
 endef
94 95
 
95 96
 define Package/ntfs-3g-utils/description
96 97
   Additional ntfs-3g utilities. Not included by default for size
97
-  considerations. All binaries except ntfs-3g, ntfs-3g.probe.
98
+  considerations.
98 99
 
99 100
   Currently:
100 101
    - ntfs-3g.secaudit
101 102
    - ntfs-3g.usermap
103
+endef
102 104
 
105
+define Package/ntfsprogs_ntfs-3g/description
106
+  Suite of NTFS utilities for doing neat things with NTFS.
107
+  Contains:
108
+   - mkntfs - Create an NTFS filesystem.
109
+   - ntfscat - Dump a file's content to the standard output.
110
+   - ntfsclone - Efficiently clone, backup, restore or rescue NTFS.
111
+   - ntfscluster - Locate the files which use the given sectors or clusters.
112
+   - ntfscmp - Compare two NTFS filesystems and tell the differences.
113
+   - ntfscp - Copy a file to an NTFS volume.
114
+   - ntfsfix - Check and fix some common errors, clear the LogFile.
115
+   - ntfsinfo - Show information about NTFS or one of the files or directories within it.
116
+   - ntfslabel - Show, or set, an NTFS filesystem's volume label.
117
+   - ntfsls - List information about files in a directory residing on an NTFS.
118
+   - ntfsresize - Resize NTFS without losing data.
119
+   - ntfsundelete - Recover deleted files from NTFS.
103 120
 endef
104 121
 
105
-# TODO: write a proper description
106
-# new in 2001.4.12
107 122
 define Package/ntfsprogs_ntfs-3g
108 123
   $(call Package/ntfs-3g/common)
109 124
   TITLE:=ntfsprogs (ntfs-3g)
@@ -199,7 +214,8 @@ endef
199 214
 
200 215
 define Package/ntfs-3g-utils/install
201 216
 	$(INSTALL_DIR) $(1)/usr/bin
202
-	$(FIND) $(PKG_INSTALL_DIR)/usr/bin/ -type f ! -name ntfs-3g.probe ! -name ntfs-3g -exec $(INSTALL_BIN) {} $(1)/usr/bin/ \;
217
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ntfs-3g.secaudit $(1)/usr/bin
218
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ntfs-3g.usermap $(1)/usr/bin
203 219
 endef
204 220
 
205 221
 define Package/ntfsprogs_ntfs-3g/install