Browse Source

devel/autoconf: add new package (closes #2190)

This patch provides package autoconf.

Autoconf is required to generated the configure script of autotools
projects.

Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>

[Fixed commit summary (first line of commit message)]

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Heinrich Schuchardt 9 years ago
parent
commit
0f1abd63f8
1 changed files with 69 additions and 0 deletions
  1. 69
    0
      devel/autoconf/Makefile

+ 69
- 0
devel/autoconf/Makefile View File

@@ -0,0 +1,69 @@
1
+#
2
+# Copyright (C) 2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=autoconf
11
+PKG_VERSION:=2.69
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE_URL:=@GNU/autoconf
15
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
16
+PKG_MD5SUM:=82d05e03b93e45f5a39b828dc9c6c29b
17
+PKG_MAINTAINER:=Heinrich Schuchardt <xypron.glpk@gmx.de>
18
+PKG_LICENSE:=GPL-3.0+
19
+
20
+PKG_INSTALL:=1
21
+
22
+include $(INCLUDE_DIR)/package.mk
23
+
24
+define Package/autoconf
25
+  SECTION:=devel
26
+  CATEGORY:=Development
27
+  TITLE:=autoconf
28
+  URL:=https://www.gnu.org/software/autoconf/
29
+  DEPENDS:=+m4 +perl +perlbase-data +perlbase-file +perlbase-getopt \
30
+  +perlbase-dynaloader +perlbase-text
31
+endef
32
+
33
+define Package/autoconf/description
34
+  Autoconf is an extensible package of M4 macros that produce shell scripts to
35
+  automatically configure software source code packages.
36
+endef
37
+
38
+define Build/Install
39
+	$(SED) 's/@PERL@/\/usr\/bin\/perl/g' $(PKG_BUILD_DIR)/bin/Makefile.in
40
+	$(call Build/Install/Default)
41
+endef
42
+
43
+define Package/autoconf/install
44
+	$(INSTALL_DIR) $(1)/usr/bin
45
+	$(SED) 's|$(STAGING_DIR_HOST)|/usr|g' $(PKG_INSTALL_DIR)/usr/bin/autom4te
46
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
47
+	$(INSTALL_DIR) $(1)/usr/share/autoconf
48
+	$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/autoconf/INSTALL \
49
+	$(1)/usr/share/autoconf/
50
+	$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/autoconf/autom4te.cfg \
51
+	$(1)/usr/share/autoconf/
52
+	$(INSTALL_DIR) $(1)/usr/share/autoconf/Autom4te
53
+	$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/autoconf/Autom4te/* \
54
+	$(1)/usr/share/autoconf/Autom4te/
55
+	$(INSTALL_DIR) $(1)/usr/share/autoconf/autoconf
56
+	$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/autoconf/autoconf/* \
57
+	$(1)/usr/share/autoconf/autoconf/
58
+	$(INSTALL_DIR) $(1)/usr/share/autoconf/autoscan
59
+	$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/autoconf/autoscan/* \
60
+	$(1)/usr/share/autoconf/autoscan/
61
+	$(INSTALL_DIR) $(1)/usr/share/autoconf/autotest
62
+	$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/autoconf/autotest/* \
63
+	$(1)/usr/share/autoconf/autotest/
64
+	$(INSTALL_DIR) $(1)/usr/share/autoconf/m4sugar
65
+	$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/autoconf/m4sugar/* \
66
+	$(1)/usr/share/autoconf/m4sugar/
67
+endef
68
+
69
+$(eval $(call BuildPackage,autoconf))