瀏覽代碼

gnunet: update source and improve packaging

 * add gnunet-vpn binary, it was missing
 * clean-up -datastore, it contained files already packaged in -mysql
 * remove gnunet-import-gns.sh from -utils, it can live in -gns

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Daniel Golle 9 年之前
父節點
當前提交
0f7454878e
共有 1 個檔案被更改,包括 5 行新增3 行删除
  1. 5
    3
      net/gnunet/Makefile

+ 5
- 3
net/gnunet/Makefile 查看文件

@@ -8,11 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gnunet
11
-PKG_SOURCE_VERSION:=36048
11
+PKG_SOURCE_VERSION:=36060
12 12
 PKG_VERSION:=0.10.1-svn$(PKG_SOURCE_VERSION)
13 13
 PKG_RELEASE:=1
14 14
 
15 15
 # ToDo:
16
+#  - properly deal with persistency
16 17
 #  - break-out {peer,name,data}store for each backend
17 18
 #  - package testing stuff
18 19
 
@@ -210,7 +211,7 @@ CONF_gns:=dns gns namecache namestore resolver
210 211
 DEPENDS_datastore:=+gnunet-gns +libsqlite3
211 212
 BIN_datastore:=datastore
212 213
 LIB_datastore:=datastore
213
-PLUGIN_datastore:=datacache_sqlite datastore_heap datastore_sqlite namecache_sqlite namestore_sqlite peerstore_sqlite
214
+PLUGIN_datastore:=datastore_heap
214 215
 LIBEXEC_datastore:=daemon-latency-logger service-datastore
215 216
 CONF_datastore:=datastore
216 217
 
@@ -230,9 +231,10 @@ PLUGIN_transport-bluetooth:=transport_bluetooth
230 231
 LIBEXEC_transport-bluetooth:=helper-transport-bluetooth
231 232
 
232 233
 DEPENDS_utils:=+certtool +openssl-util
233
-BIN_utils:=config gns-proxy-setup-ca transport-certificate-creation
234
+BIN_utils:=gns-proxy-setup-ca transport-certificate-creation
234 235
 
235 236
 DEPENDS_vpn:=+kmod-tun
237
+BIN_vpn:=vpn
236 238
 LIB_vpn:=tun vpn
237 239
 LIBEXEC_vpn:=daemon-exit daemon-pt helper-exit helper-vpn service-vpn
238 240
 CONF_vpn:=exit pt vpn