Przeglądaj źródła

ibrdtnd: Updated to 1.0.0

Signed-off-by: Johannes Morgenroth <jm@m-network.de>
Johannes Morgenroth 10 lat temu
rodzic
commit
111d3f9d84

+ 5
- 5
net/ibrdtnd/Makefile Wyświetl plik

@@ -8,17 +8,16 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=ibrdtnd
11
-PKG_VERSION:=0.12.1
11
+PKG_VERSION:=1.0.0
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
16
-PKG_MD5SUM:=8dad5ebbcfaa4c16ba151c9c289066c3
17
-PKG_MAINTAINER:=Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
16
+PKG_MD5SUM:=7fd48b2eec5058fa15f6977afd4e8dab
17
+PKG_MAINTAINER:=Johannes Morgenroth <jm@m-network.de>
18 18
 PKG_LICENSE:=Apache-2.0
19 19
 
20 20
 PKG_INSTALL:=1
21
-PKG_FIXUP:=autoreconf
22 21
 
23 22
 include $(INCLUDE_DIR)/package.mk
24 23
 
@@ -26,7 +25,7 @@ define Package/ibrdtnd
26 25
   SECTION:=net
27 26
   CATEGORY:=Network
28 27
   DEPENDS:=+dtndht +ibrdtn +libsqlite3
29
-  TITLE:=DTN Deamon
28
+  TITLE:=DTN Daemon
30 29
 endef
31 30
 
32 31
 define Package/ibrdtnd/conffiles
@@ -40,6 +39,7 @@ endef
40 39
 CONFIGURE_ARGS += \
41 40
 	--with-tls \
42 41
 	--with-sqlite \
42
+	--with-dht \
43 43
 	--without-wifip2p \
44 44
 	--without-vmime \
45 45
 	--disable-libdaemon

+ 5
- 0
net/ibrdtnd/files/build-config.sh Wyświetl plik

@@ -116,6 +116,7 @@ add_param $CONFFILE "ibrdtn.dht.allow_neighbour_announcement" "dht_allow_neighbo
116 116
 # iterate through all network interfaces
117 117
 iter=0
118 118
 netinterfaces=
119
+netinternet=
119 120
 while [ 1 == 1 ]; do
120 121
 	$UCI -q get "ibrdtn.@network[$iter]" > /dev/null
121 122
 	if [ $? == 0 ]; then
@@ -123,6 +124,9 @@ while [ 1 == 1 ]; do
123 124
 		add_param $CONFFILE "ibrdtn.@network[$iter].type" "net_lan${iter}_type"
124 125
 		add_param $CONFFILE "ibrdtn.@network[$iter].interface" "net_lan${iter}_interface"
125 126
 		add_param $CONFFILE "ibrdtn.@network[$iter].port" "net_lan${iter}_port"
127
+		if [ "$(uci -q get ibrdtn.@network[$iter].global)" == "yes" ]; then
128
+			netinternet="${netinternet} $(uci -q get ibrdtn.@network[$iter].interface)"
129
+		fi
126 130
 	else
127 131
 		break
128 132
 	fi
@@ -132,6 +136,7 @@ done
132 136
 
133 137
 # write list of network interfaces
134 138
 echo "net_interfaces =$netinterfaces" >> $CONFFILE
139
+echo "net_internet =${netinternet}" >> $CONFFILE
135 140
 
136 141
 # iterate through all static routes
137 142
 iter=0

+ 1
- 0
net/ibrdtnd/files/ibrdtn.uci Wyświetl plik

@@ -109,6 +109,7 @@ config 'network'
109 109
 	option type			tcp
110 110
 	option interface	eth0
111 111
 	option port			4556
112
+	option global		yes
112 113
 	
113 114
 #config 'network'
114 115
 #	option type			tcp

+ 0
- 74
net/ibrdtnd/patches/100-add_configure_options.patch Wyświetl plik

@@ -1,75 +0,0 @@
1
---- a/configure.ac
2
-+++ b/configure.ac
3
-@@ -333,30 +333,46 @@ AS_IF([test "x$enable_android" = "xyes"], [
4
- 	dnl optional parameter: Wifi-P2P support
5
- 	dnl -----------------------------------------------
6
- 
7
--	PKG_CHECK_MODULES([WIFIP2P], wifip2p >= 0.1 , [
8
--				with_wifi_p2p="yes"
9
--				AC_SUBST(WIFIP2P_CFLAGS)
10
--				AC_SUBST(WIFIP2P_LIBS)
11
--				AC_DEFINE(WITH_WIFIP2P, [1], ["wifi-p2p support enabled"])
12
--			], [
13
--				with_wifi_p2p="no"
14
--				AC_MSG_WARN([wifi-p2p library not found. wifi-p2p support is disabled.])
15
--			])
16
-+	AC_ARG_WITH([wifip2p],
17
-+		AS_HELP_STRING([--without-wifip2p], [Build without wifip2p support]),
18
-+		[
19
-+			with_wifi_p2p="no"
20
-+			AC_MSG_NOTICE([WIFIP2P support disabled])
21
-+		], [
22
-+			PKG_CHECK_MODULES([WIFIP2P], wifip2p >= 0.1 , [
23
-+						with_wifi_p2p="yes"
24
-+						AC_SUBST(WIFIP2P_CFLAGS)
25
-+						AC_SUBST(WIFIP2P_LIBS)
26
-+						AC_DEFINE(WITH_WIFIP2P, [1], ["wifi-p2p support enabled"])
27
-+					], [
28
-+						with_wifi_p2p="no"
29
-+						AC_MSG_WARN([wifi-p2p library not found. wifi-p2p support is disabled.])
30
-+					])
31
-+		]
32
-+	)
33
- 
34
--    dnl -----------------------------------------------
35
--    dnl optional parameter: VMime support
36
--    dnl -----------------------------------------------
37
--
38
--    PKG_CHECK_MODULES([VMIME], vmime >= 0.9.1 , [
39
--                with_vmime="yes"
40
--                AC_SUBST(VMIME_CFLAGS)
41
--                AC_SUBST(VMIME_LIBS)
42
--                AC_DEFINE(HAVE_VMIME, [1], ["Email Convergence Layer is available"])
43
--                AC_CHECK_HEADERS([vmime/utility/smartPtrInt.hpp])
44
--            ], [
45
--                with_vmime="no"
46
--                AC_MSG_WARN([VMime library not found. Email Convergence Layer is disabled.])
47
--            ])
48
-+	dnl -----------------------------------------------
49
-+	dnl optional parameter: VMime support
50
-+	dnl -----------------------------------------------
51
-+
52
-+	AC_ARG_WITH([vmime],
53
-+		AS_HELP_STRING([--without-vmime], [Build without vmime support]),
54
-+		[
55
-+			with_vmime="no"
56
-+			AC_MSG_NOTICE([VMIME support disabled])
57
-+		], [
58
-+			PKG_CHECK_MODULES([VMIME], vmime >= 0.9.1 , [
59
-+						with_vmime="yes"
60
-+						AC_SUBST(VMIME_CFLAGS)
61
-+						AC_SUBST(VMIME_LIBS)
62
-+						AC_DEFINE(HAVE_VMIME, [1], ["Email Convergence Layer is available"])
63
-+						AC_CHECK_HEADERS([vmime/utility/smartPtrInt.hpp])
64
-+					], [
65
-+						with_vmime="no"
66
-+						AC_MSG_WARN([VMime library not found. Email Convergence Layer is disabled.])
67
-+					])
68
-+		]
69
-+	)
70
- 
71
- 	dnl -----------------------------------------------
72
- 	dnl check for regex capabilities
73
-1.9.1
74
-

+ 0
- 25
net/ibrdtnd/patches/110-add_configure_options_docs.patch Wyświetl plik

@@ -1,26 +0,0 @@
1
---- a/configure.ac
2
-+++ b/configure.ac
3
-@@ -138,11 +138,17 @@ AS_IF([test "x$enable_android" = "xyes"], [
4
- 	# Checks for library functions.
5
- 	AC_CHECK_FUNCS([gethostname socket])
6
- 
7
--	# Check for presence of pdfLaTeX
8
--	AC_CHECK_PROG(PDFLATEX, pdflatex, pdflatex)
9
--	if test -z "$PDFLATEX"; then
10
--	AC_MSG_WARN([Unable to create PDF version of the documentation.])
11
--	fi
12
-+	AC_ARG_ENABLE([docs],
13
-+		AS_HELP_STRING([--enable-docs], [Build documentation using PDFLaTeX]),
14
-+	[
15
-+		# Check for presence of pdfLaTeX
16
-+		AC_CHECK_PROG(PDFLATEX, pdflatex, pdflatex)
17
-+		if test -z "$PDFLATEX"; then
18
-+			AC_MSG_WARN([Unable to create PDF version of the documentation.])
19
-+		fi
20
-+	], [
21
-+		PDFLATEX="no"
22
-+	])
23
- 
24
- 	AC_ARG_ENABLE([libdaemon],
25
- 		AS_HELP_STRING([--disable-libdaemon], [Build without libdaemon support]),