瀏覽代碼

Merge pull request #1158 from commodo/python-ncurses

python: force libncurses
Steven Barth 9 年之前
父節點
當前提交
14f680ea3b
共有 2 個文件被更改,包括 16 次插入1 次删除
  1. 1
    1
      lang/python/files/python-package-ncurses.mk
  2. 15
    0
      lang/python/patches/011-do-not-prefer-ncursesw.patch

+ 1
- 1
lang/python/files/python-package-ncurses.mk 查看文件

@@ -8,7 +8,7 @@
8 8
 define Package/python-ncurses
9 9
 $(call Package/python/Default)
10 10
   TITLE:=Python $(PYTHON_VERSION) ncurses module
11
-  DEPENDS:=+python-light +libncursesw
11
+  DEPENDS:=+python-light +libncurses
12 12
 endef
13 13
 
14 14
 $(eval $(call PyBasePackage,python-ncurses, \

+ 15
- 0
lang/python/patches/011-do-not-prefer-ncursesw.patch 查看文件

@@ -0,0 +1,15 @@
1
+diff --git a/setup.py b/setup.py
2
+index 7868b7b..86b0119 100644
3
+--- a/setup.py
4
++++ b/setup.py
5
+@@ -725,8 +725,8 @@ class PyBuildExt(build_ext):
6
+         # use the same library for the readline and curses modules.
7
+         if 'curses' in readline_termcap_library:
8
+             curses_library = readline_termcap_library
9
+-        elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
10
+-            curses_library = 'ncursesw'
11
++        #elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
12
++        #    curses_library = 'ncursesw'
13
+         elif self.compiler.find_library_file(lib_dirs, 'ncurses'):
14
+             curses_library = 'ncurses'
15
+         elif self.compiler.find_library_file(lib_dirs, 'curses'):