Browse Source

python: do not prefer ncursesw over ncurses

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Alexandru Ardelean 9 years ago
parent
commit
1dc9306558
1 changed files with 15 additions and 0 deletions
  1. 15
    0
      lang/python/patches/011-do-not-prefer-ncursesw.patch

+ 15
- 0
lang/python/patches/011-do-not-prefer-ncursesw.patch View File

@@ -0,0 +1,15 @@
1
+diff --git a/setup.py b/setup.py
2
+index 7868b7b..86b0119 100644
3
+--- a/setup.py
4
++++ b/setup.py
5
+@@ -725,8 +725,8 @@ class PyBuildExt(build_ext):
6
+         # use the same library for the readline and curses modules.
7
+         if 'curses' in readline_termcap_library:
8
+             curses_library = readline_termcap_library
9
+-        elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
10
+-            curses_library = 'ncursesw'
11
++        #elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
12
++        #    curses_library = 'ncursesw'
13
+         elif self.compiler.find_library_file(lib_dirs, 'ncurses'):
14
+             curses_library = 'ncurses'
15
+         elif self.compiler.find_library_file(lib_dirs, 'curses'):