Browse Source

moc: import from oldpackages, add LICENSE info, add myself as pkg maintainer

Signed-off-by: Ted Hess <thess@kitschensync.net>
Ted Hess 10 years ago
parent
commit
1df66cd47b
1 changed files with 64 additions and 0 deletions
  1. 64
    0
      sound/mocp/Makefile

+ 64
- 0
sound/mocp/Makefile View File

@@ -0,0 +1,64 @@
1
+#
2
+# Copyright (C) 2011-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=moc
11
+PKG_VERSION:=2.5.0-beta2
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15
+PKG_SOURCE_URL:=http://ftp.daper.net/pub/soft/moc/unstable/
16
+PKG_MD5SUM:=da87b90b57934234589b63e347921458
17
+
18
+PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
19
+
20
+PKG_LICENSE:=GPL-2.0
21
+PKG_LICENSE_FILE:=COPYING
22
+
23
+PKG_FIXUP:=autoreconf
24
+PKG_INSTALL:=1
25
+
26
+include $(INCLUDE_DIR)/package.mk
27
+include $(INCLUDE_DIR)/nls.mk
28
+
29
+define Package/moc
30
+  SECTION:=sound
31
+  CATEGORY:=Sound
32
+  DEPENDS:=+libcurl +BUILD_PATENTED:libmad +libvorbis $(ICONV_DEPENDS) +alsa-lib +libid3tag +libflac +libsamplerate +PACKAGE_libncursesw:libncursesw +!PACKAGE_libncursesw:libncurses +libffmpeg +libltdl +libmagic +faad2 +libdb47
33
+  TITLE:=Music On Console
34
+  URL:=http://moc.daper.net/
35
+endef
36
+
37
+define Package/moc/description
38
+	MOC (music on console) is a console audio player for LINUX/UNIX designed to be powerful and easy to use.
39
+endef
40
+
41
+define Build/Configure
42
+	$(call Build/Configure/Default, \
43
+		$(if $(CONFIG_BUILD_PATENTED),,--without-mp3) \
44
+		--enable-shared \
45
+		--disable-static \
46
+		--disable-debug \
47
+		--without-speex \
48
+		--without-samplerate \
49
+		--without-curl \
50
+		--without-flac \
51
+		--without-musepack \
52
+		--without-rcc \
53
+		$(if $(CONFIG_PACKAGE_libncursesw),--with-ncursesw --without-ncurses,--with-ncurses --without-ncursesw) \
54
+	)
55
+endef
56
+
57
+define Package/moc/install
58
+	$(INSTALL_DIR) $(1)/usr/bin
59
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mocp $(1)/usr/bin/
60
+	$(INSTALL_DIR) $(1)/usr/lib/moc/decoder_plugins
61
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/moc/decoder_plugins/*.so $(1)/usr/lib/moc/decoder_plugins
62
+endef
63
+
64
+$(eval $(call BuildPackage,moc))