Browse Source

libsamplerate: import from oldpackages, upgrade to 0.1.8, fix build, add myself as pkg maintainer

Signed-off-by: Ted Hess <thess@kitschensync.net>
Ted Hess 10 years ago
parent
commit
6f937821fc
1 changed files with 55 additions and 0 deletions
  1. 55
    0
      libs/libsamplerate/Makefile

+ 55
- 0
libs/libsamplerate/Makefile View File

@@ -0,0 +1,55 @@
1
+#
2
+# Copyright (C) 2007-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=libsamplerate
11
+PKG_VERSION:=0.1.8
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=http://www.mega-nerd.com/SRC/
16
+PKG_MD5SUM:=1c7fb25191b4e6e3628d198a66a84f47
17
+
18
+PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
19
+
20
+PKG_LICENSE:=GPL-2.0
21
+PKG_LICENSE_FILE:=COPYING
22
+
23
+PKG_INSTALL:=1
24
+
25
+include $(INCLUDE_DIR)/package.mk
26
+
27
+define Package/libsamplerate
28
+  SECTION:=libs
29
+  CATEGORY:=Libraries
30
+  DEPENDS:=+libsndfile
31
+  TITLE:=Sample Rate Converter
32
+  URL:=http://www.mega-nerd.com/SRC/index.html
33
+endef
34
+
35
+define Package/libsamplerate/description
36
+ Secret Rabbit Code (aka libsamplerate) is a Sample Rate
37
+ Converter for audio.
38
+endef
39
+
40
+TARGET_CFLAGS += $(FPIC)
41
+
42
+CONFIGURE_ARGS += \
43
+	--disable-fftw \
44
+
45
+define Build/InstallDev
46
+	$(INSTALL_DIR) $(1)
47
+	$(CP) $(PKG_INSTALL_DIR)/* $(1)/
48
+endef
49
+
50
+define Package/libsamplerate/install
51
+	$(INSTALL_DIR) $(1)/usr/lib
52
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libsamplerate.so.* $(1)/usr/lib/
53
+endef
54
+
55
+$(eval $(call BuildPackage,libsamplerate))