Browse Source

dmx_usb_module: new package added

dmx_usb_module is a kernel module that is needed to controll FTDI485 based DMX modules.

Signed-off-by: Martijn Zilverschoon <martijn@friedzombie.com>
Martijn Zilverschoon 10 years ago
parent
commit
1f9485a894

+ 56
- 0
libs/dmx_usb_module/Makefile View File

@@ -0,0 +1,56 @@
1
+#
2
+# Copyright (C) 2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+include $(INCLUDE_DIR)/kernel.mk
10
+
11
+PKG_NAME:=dmx_usb_module
12
+PKG_VERSION:=0.1.20130818
13
+PKG_RELEASE:=0.1
14
+
15
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
16
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
17
+PKG_SOURCE_URL:=git://github.com/lowlander/dmx_usb_module.git
18
+PKG_SOURCE_PROTO:=git
19
+PKG_SOURCE_VERSION:=ee99ca7edbd9e093480ad63341ac007394047bde
20
+PKG_MAINTAINER:=Martijn Zilverschoon <martijn@friedzombie.com>
21
+PKG_LICENSE:=GPL-2.0
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+
25
+define KernelPackage/usb-serial-dmx_usb_module
26
+	SECTION:=kernel
27
+	CATEGORY:=Kernel modules
28
+	SUBMENU:=USB Support
29
+	TITLE:=Support for FTDI RS485 based DMX modules
30
+	URL:=http://www.erwinrol.com/open-dmx-usb-linux-driver/
31
+	FILES:=$(PKG_BUILD_DIR)/dmx_usb.$(LINUX_KMOD_SUFFIX)
32
+	AUTOLOAD:=$(call AutoProbe,dmx_usb)
33
+	DEPENDS+=kmod-usb-serial
34
+endef
35
+
36
+define KernelPackage/usb-serial-dmx_usb_module/description
37
+	Open DMX USB is an open USB to DMX dongle hardware design developed by Enttec.
38
+	The Open in Open DMX USB refers to the fact that everybody is free to use the
39
+	design and produce its own USB DMX Dongle without paying any licenses.
40
+endef
41
+
42
+DMX_MAKE_OPTS:= -C $(PKG_BUILD_DIR) \
43
+	PATH="$(TARGET_PATH)" \
44
+	ARCH="$(LINUX_KARCH)" \
45
+	CROSS_COMPILE="$(TARGET_CROSS)" \
46
+	TARGET="$(HAL_TARGET)" \
47
+	TOOLPREFIX="$(KERNEL_CROSS)" \
48
+	TOOLPATH="$(KERNEL_CROSS)" \
49
+	KERNELPATH="$(LINUX_DIR)" \
50
+	LDOPTS=" "
51
+
52
+define Build/Compile
53
+  $(MAKE) $(DMX_MAKE_OPTS) M=$(PKG_BUILD_DIR)
54
+endef
55
+
56
+$(eval $(call KernelPackage,usb-serial-dmx_usb_module))

+ 13
- 0
libs/dmx_usb_module/patches/001-dmx_usb_Makefile.patch View File

@@ -0,0 +1,13 @@
1
+--- a/Makefile
2
++++ b/Makefile
3
+@@ -12,8 +12,7 @@ KDIR	:= /lib/modules/$(shell uname -r)/build
4
+ PWD	:= $(shell pwd)
5
+ 
6
+ default:
7
+-	$(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
8
+-	gcc -O2 -pipe -Wall dmx_usb_test.c -o dmx_usb_test
9
++	$(MAKE) -C $(KERNELPATH) SUBDIRS=$(PWD) modules
10
+ 
11
+ endif
12
+ 
13
+