Browse Source

luaposix: update to v33.0.0

Signed-off-by: Maxim Storchak <m.storchak@gmail.com>
Maxim Storchak 10 years ago
parent
commit
24e41808dc

+ 4
- 3
lang/luaposix/Makefile View File

@@ -8,17 +8,18 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=luaposix
11
-PKG_VERSION:=v32
11
+PKG_VERSION:=v33.0.0
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=release-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=https://github.com/luaposix/luaposix/archive/
16
-PKG_MD5SUM:=2bfede7b7cee96c5d0f6c0354e17498c
16
+PKG_MD5SUM:=3241c33566542b7563ae001112646af6
17 17
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-release-$(PKG_VERSION)
18 18
 PKG_REMOVE_FILES:=aclocal.m4
19 19
 PKG_FIXUP:=autoreconf
20 20
 PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
21 21
 PKG_LICENSE:=MIT
22
+PKG_LICENSE_FILES:=COPYING
22 23
 
23 24
 include $(INCLUDE_DIR)/package.mk
24 25
 
@@ -48,7 +49,7 @@ endif
48 49
 
49 50
 define Package/luaposix/install
50 51
 	$(INSTALL_DIR) $(1)/usr/lib/lua
51
-	$(INSTALL_BIN) $(PKG_BUILD_DIR)/ext/posix/.libs/posix_c.so $(1)/usr/lib/lua
52
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/ext/posix/.libs/posix.so $(1)/usr/lib/lua
52 53
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/posix.lua $(1)/usr/lib/lua
53 54
 endef
54 55
 

+ 20
- 19
lang/luaposix/patches/100-eglibc-compat.patch View File

@@ -1,28 +1,29 @@
1
---- a/ext/posix/posix.c
2
-+++ b/ext/posix/posix.c
3
-@@ -1970,6 +1970,7 @@ static int Pctermid(lua_State *L)
4
- 	return 1;
5
- }
1
+diff -Naur luaposix-release-v33.0.0.orig/ext/posix/unistd.c luaposix-release-v33.0.0/ext/posix/unistd.c
2
+--- luaposix-release-v33.0.0.orig/ext/posix/unistd.c	2014-11-04 17:49:35.000000000 +0200
3
++++ luaposix-release-v33.0.0/ext/posix/unistd.c	2014-12-14 00:59:14.878622722 +0200
4
+@@ -526,6 +526,7 @@
5
+ #endif
6
+ 
6 7
  
7 8
 +#ifndef NO_GETLOGIN
8 9
  /***
9 10
  Current logged-in user.
10
- @see getlogin(3)
11
-@@ -1980,6 +1981,7 @@ static int Pgetlogin(lua_State *L)
12
- 	lua_pushstring(L, getlogin());
13
- 	return 1;
11
+ @treturn[1] string username, if successful
12
+@@ -538,6 +539,7 @@
13
+ 	checknargs(L, 0);
14
+ 	return pushstringresult(getlogin());
14 15
  }
15 16
 +#endif
16 17
  
17
- static void Fgetpasswd(lua_State *L, int i, const void *data)
18
- {
19
-@@ -3786,7 +3788,9 @@ static const luaL_Reg R[] =
20
- #if _POSIX_VERSION >= 200112L
21
- 	MENTRY( Pgetgroups	),
22
- #endif
18
+ 
19
+ /***
20
+@@ -1037,7 +1039,9 @@
21
+ 	LPOSIX_FUNC( Pgetegid		),
22
+ 	LPOSIX_FUNC( Pgeteuid		),
23
+ 	LPOSIX_FUNC( Pgetgid		),
23 24
 +#ifndef NO_GETLOGIN
24
- 	MENTRY( Pgetlogin	),
25
+ 	LPOSIX_FUNC( Pgetlogin		),
25 26
 +#endif
26
- 	MENTRY( Pgetopt		),
27
- 	MENTRY( Pgetpasswd	),
28
- 	MENTRY( Pgetpid		),
27
+ 	LPOSIX_FUNC( Pgetpgrp		),
28
+ 	LPOSIX_FUNC( Pgetpid		),
29
+ 	LPOSIX_FUNC( Pgetppid		),

+ 30
- 0
lang/luaposix/patches/101-disable-curses.patch View File

@@ -0,0 +1,30 @@
1
+diff -Naur luaposix-release-v33.0.0.orig/ext/posix/posix.c luaposix-release-v33.0.0/ext/posix/posix.c
2
+--- luaposix-release-v33.0.0.orig/ext/posix/posix.c	2014-11-04 17:49:35.000000000 +0200
3
++++ luaposix-release-v33.0.0/ext/posix/posix.c	2014-12-14 01:49:44.486562194 +0200
4
+@@ -11,7 +11,6 @@
5
+  */
6
+ 
7
+ #include "ctype.c"
8
+-#include "curses.c"
9
+ #include "dirent.c"
10
+ #include "errno.c"
11
+ #include "fcntl.c"
12
+diff -Naur luaposix-release-v33.0.0.orig/configure.ac luaposix-release-v33.0.0/configure.ac
13
+--- luaposix-release-v33.0.0.orig/configure.ac	2014-11-04 17:49:35.000000000 +0200
14
++++ luaposix-release-v33.0.0/configure.ac	2014-12-14 01:58:08.214554482 +0200
15
+@@ -109,15 +109,6 @@
16
+   AC_SUBST([LIBRT], [-lrt])
17
+ fi
18
+ 
19
+-dnl Curses
20
+-AX_WITH_CURSES
21
+-AC_ARG_VAR(CURSES_LIB, [linker flags for curses library])
22
+-
23
+-save_LIBS=$LIBS
24
+-LIBS="$CURSES_LIB $LIBS"
25
+-AC_CHECK_FUNCS([resizeterm])
26
+-LIBS=$save_LIBS
27
+-
28
+ dnl Lua 5.1 or 5.2
29
+ AX_PROG_LUA(5.1, 5.3)
30
+ AX_LUA_HEADERS