Browse Source

opus: import new package

Opus is a totally open, royalty-free, highly versatile audio codec.

Signed-off-by: Nicolas Thill <nico@openwrt.org>
Nicolas Thill 10 years ago
parent
commit
265f6bfb21
1 changed files with 53 additions and 0 deletions
  1. 53
    0
      libs/opus/Makefile

+ 53
- 0
libs/opus/Makefile View File

@@ -0,0 +1,53 @@
1
+#
2
+# Copyright (C) 2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=opus
11
+PKG_VERSION:=1.1
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=http://downloads.xiph.org/releases/opus/
16
+PKG_MD5SUM:=c5a8cf7c0b066759542bc4ca46817ac6
17
+
18
+PKG_LICENSE:=BSD-3-Clause
19
+PKG_LICENSE_FILE:=COPYING
20
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
21
+
22
+PKG_INSTALL:=1
23
+
24
+include $(INCLUDE_DIR)/package.mk
25
+
26
+define Package/libopus
27
+  SECTION:=libs
28
+  CATEGORY:=Libraries
29
+  TITLE:=OPUS Codec
30
+  URL:=http://opus-codec.org/
31
+endef
32
+
33
+define Package/libopus/description
34
+ Opus is a totally open, royalty-free, highly versatile audio codec. Opus is 
35
+ unmatched for interactive speech and music transmission over the Internet, but 
36
+ is also intended for storage and streaming applications.
37
+endef
38
+
39
+define Build/InstallDev
40
+	$(INSTALL_DIR) $(1)/usr/include
41
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/opus $(1)/usr/include/
42
+	$(INSTALL_DIR) $(1)/usr/lib
43
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libopus.so* $(1)/usr/lib/
44
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
45
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/opus.pc $(1)/usr/lib/pkgconfig/
46
+endef
47
+
48
+define Package/libopus/install
49
+	$(INSTALL_DIR) $(1)/usr/lib
50
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libopus.so.* $(1)/usr/lib/
51
+endef
52
+
53
+$(eval $(call BuildPackage,libopus))