浏览代码

node-arduino-firmata: set proper download path and set version properly

* fix download path
* fix version variables

Signed-off-by: John Crispin <blogic@openwrt.org>
John Crispin 9 年前
父节点
当前提交
2c82144c59
共有 1 个文件被更改,包括 7 次插入3 次删除
  1. 7
    3
      lang/node-arduino-firmata/Makefile

+ 7
- 3
lang/node-arduino-firmata/Makefile 查看文件

@@ -12,14 +12,18 @@ PKG_NAME:=node-$(PKG_NPM_NAME)
12 12
 PKG_VERSION:=0.3.3
13 13
 PKG_RELEASE:=1
14 14
 
15
-PKG_SOURCE:=v$(PKG_VERSION).tar.gz
16
-PKG_SOURCE_URL:=https://github.com/shokai/node-arduino-firmata/archive/
15
+PKG_SOURCE_PROTO:=git
16
+PKG_SOURCE_URL:=https://github.com/shokai/node-arduino-firmata.git
17
+PKG_SOURCE_VERSION:=16e76007edf218d72df590adbd711ac6b7432845
18
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_SOURCE_VERSION)
19
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz
17 20
 
18 21
 PKG_BUILD_DEPENDS:=node
19 22
 PKG_NODE_VERSION:=0.12.7
20 23
 
21 24
 PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
22
-PKG_LICENSE:=
25
+PKG_LICENSE:=MIT
26
+PKG_LICENSE_FILE:=LICENSE.txt
23 27
 
24 28
 include $(INCLUDE_DIR)/package.mk
25 29