|
@@ -0,0 +1,82 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2013-2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=zsh
|
|
11
|
+PKG_VERSION:=5.0.6
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
15
|
+PKG_SOURCE_URL:=@SF/zsh
|
|
16
|
+PKG_MD5SUM:=7150a6abc2aa1a79d81ed9a282594225
|
|
17
|
+PKG_MAINTAINER:=Vadim A. Misbakh-Soloviov <mva@mva.name>
|
|
18
|
+PKG_LICENSE:=ZSH
|
|
19
|
+
|
|
20
|
+PKG_INSTALL:=1
|
|
21
|
+
|
|
22
|
+include $(INCLUDE_DIR)/package.mk
|
|
23
|
+
|
|
24
|
+define Package/zsh
|
|
25
|
+ SECTION:=utils
|
|
26
|
+ CATEGORY:=Utilities
|
|
27
|
+ TITLE:=The Z shell
|
|
28
|
+ DEPENDS:=+libncurses +libncursesw +libpcre +librt
|
|
29
|
+ URL:=http://www.zsh.org/
|
|
30
|
+endef
|
|
31
|
+
|
|
32
|
+define Package/zsh/description
|
|
33
|
+ Zsh is a UNIX command interpreter (shell) usable as an interactive
|
|
34
|
+ login shell and as a shell script command processor. Of the standard
|
|
35
|
+ shells, zsh most closely resembles ksh but includes many enhancements.
|
|
36
|
+ Zsh has command line editing, builtin spelling correction, programmable
|
|
37
|
+ command completion, shell functions (with autoloading), a history
|
|
38
|
+ mechanism, and a host of other features.
|
|
39
|
+endef
|
|
40
|
+
|
|
41
|
+define Build/Configure
|
|
42
|
+ $(call Build/Configure/Default, \
|
|
43
|
+ --bindir=/bin \
|
|
44
|
+ --disable-etcdir \
|
|
45
|
+ --disable-gdbm \
|
|
46
|
+ --enable-pcre \
|
|
47
|
+ --enable-multibyte \
|
|
48
|
+ --enable-function-subdirs \
|
|
49
|
+ --with-tcsetpgrp \
|
|
50
|
+ --with-term-lib="ncursesw", \
|
|
51
|
+ zsh_cv_sys_nis=no \
|
|
52
|
+ zsh_cv_sys_nis_plus=no \
|
|
53
|
+ )
|
|
54
|
+ # Do not install these functions:
|
|
55
|
+ $(SED) 's, Completion/AIX/\*/\*,,g' $(PKG_BUILD_DIR)/config.modules
|
|
56
|
+ $(SED) 's, Completion/BSD/\*/\*,,g' $(PKG_BUILD_DIR)/config.modules
|
|
57
|
+ $(SED) 's, Completion/Cygwin/\*/\*,,g' $(PKG_BUILD_DIR)/config.modules
|
|
58
|
+ $(SED) 's, Completion/Darwin/\*/\*,,g' $(PKG_BUILD_DIR)/config.modules
|
|
59
|
+ $(SED) 's, Completion/Debian/\*/\*,,g' $(PKG_BUILD_DIR)/config.modules
|
|
60
|
+ $(SED) 's, Completion/Mandriva/\*/\*,,g' $(PKG_BUILD_DIR)/config.modules
|
|
61
|
+ $(SED) 's, Completion/Redhat/\*/\*,,g' $(PKG_BUILD_DIR)/config.modules
|
|
62
|
+ $(SED) 's, Completion/Solaris/\*/\*,,g' $(PKG_BUILD_DIR)/config.modules
|
|
63
|
+ $(SED) 's, Completion/X/\*/\*,,g' $(PKG_BUILD_DIR)/config.modules
|
|
64
|
+ $(SED) 's, Completion/openSUSE/\*/\*,,g' $(PKG_BUILD_DIR)/config.modules
|
|
65
|
+ # After mucking with 'config.modules', one must call
|
|
66
|
+ $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" prep
|
|
67
|
+endef
|
|
68
|
+
|
|
69
|
+define Package/zsh/postinst
|
|
70
|
+#!/bin/sh
|
|
71
|
+grep zsh $${IPKG_INSTROOT}/etc/shells || \
|
|
72
|
+ echo "/bin/zsh" >> $${IPKG_INSTROOT}/etc/shells
|
|
73
|
+endef
|
|
74
|
+
|
|
75
|
+define Package/zsh/install
|
|
76
|
+ $(INSTALL_DIR) $(1)/bin
|
|
77
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/zsh $(1)/bin/
|
|
78
|
+ $(INSTALL_DIR) $(1)/usr/share/zsh/$(PKG_VERSION)
|
|
79
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/share/zsh/$(PKG_VERSION)/* $(1)/usr/share/zsh/$(PKG_VERSION)/
|
|
80
|
+endef
|
|
81
|
+
|
|
82
|
+$(eval $(call BuildPackage,zsh))
|