瀏覽代碼

ices: import from old packages feed

 - update to latest version (v2.0.2)
 - add license info
 - add myself as maintainer

Signed-off-by: Nicolas Thill <nico@openwrt.org>
Nicolas Thill 10 年之前
父節點
當前提交
38ae2398c2
共有 1 個文件被更改,包括 51 次插入0 次删除
  1. 51
    0
      multimedia/ices/Makefile

+ 51
- 0
multimedia/ices/Makefile 查看文件

@@ -0,0 +1,51 @@
1
+#
2
+# Copyright (C) 2009-2015 OpenWrt.org
3
+# Copyright (C) 2009 Freifunk Leipzig
4
+#
5
+# This is free software, licensed under the GNU General Public License v2.
6
+# See /LICENSE for more information.
7
+#
8
+
9
+include $(TOPDIR)/rules.mk
10
+
11
+PKG_NAME:=ices
12
+PKG_VERSION:=2.0.2
13
+PKG_RELEASE:=1
14
+
15
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
16
+PKG_SOURCE_URL:=http://downloads.xiph.org/releases/ices/
17
+PKG_MD5SUM:=832c448cc993170a70fd95804fcda5b2
18
+
19
+PKG_LICENSE:=GPL-2.0
20
+PKG_LICENSE_FILES:=COPYING
21
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
22
+
23
+PKG_FIXUP:=autoreconf
24
+PKG_INSTALL:=1
25
+
26
+include $(INCLUDE_DIR)/package.mk
27
+
28
+define Package/ices
29
+  SECTION:=sound
30
+  CATEGORY:=Sound
31
+  TITLE:=ices client for Icecast media streaming servers
32
+  URL:=http://www.icecast.org/ices/
33
+  DEPENDS:=+libshout +libxml2 +zlib +libogg +libvorbis +alsa-lib
34
+endef
35
+
36
+define Package/ices/description
37
+  ices is a command line source client for Icecast media streaming servers.
38
+  It began as the successor of the old "shout" utility, and has since gained a
39
+  lot of useful features.
40
+endef
41
+
42
+CONFIGURE_ARGS+= \
43
+	--with-ogg="$(STAGING_DIR)/usr/include" \
44
+	--with-vorbis="$(STAGING_DIR)/usr/include" \
45
+
46
+define Package/ices/install
47
+	$(INSTALL_DIR) $(1)/usr/bin
48
+	$(CP) $(PKG_INSTALL_DIR)/usr/bin/ices $(1)/usr/bin/
49
+endef
50
+
51
+$(eval $(call BuildPackage,ices))