Browse Source

libshout: import from old packages feed

 - add license info
 - add myself as maintainer

Signed-off-by: Nicolas Thill <nico@openwrt.org>
Nicolas Thill 10 years ago
parent
commit
dd17d21b2f

+ 68
- 0
libs/libshout/Makefile View File

@@ -0,0 +1,68 @@
1
+#
2
+# Copyright (C) 2008-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=libshout
11
+PKG_VERSION:=2.3.1
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/libshout/
16
+PKG_MD5SUM:=11765b2592e7ea623ccd93d3f8df172c
17
+
18
+PKG_LICENSE:=LGPL-2.0+
19
+PKG_LICENSE_FILES:=COPYING
20
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
21
+
22
+PKG_FIXUP:=autoreconf
23
+PKG_INSTALL:=1
24
+
25
+include $(INCLUDE_DIR)/package.mk
26
+
27
+define Package/libshout
28
+  SECTION:=libs
29
+  CATEGORY:=Libraries
30
+  TITLE:=Library which can be used to write a source client like ices
31
+  URL:=http://www.icecast.org/download.php
32
+  DEPENDS:= +libspeex +libtheora +libvorbis +libvorbisidec +libpthread
33
+endef
34
+
35
+define Package/libshout/description
36
+ libshout allows applications to easily communicate and broadcast
37
+ to an Icecast streaming media server. It handles the socket connections,
38
+ metadata communication, and data streaming for the calling application,
39
+ and lets developers focus on feature sets instead of implementation
40
+ details.
41
+endef
42
+
43
+CONFIGURE_ARGS += \
44
+	--enable-shared \
45
+	--enable-static \
46
+
47
+CONFIGURE_VARS += \
48
+	VORBIS_CFLAGS="-I$(STAGING_DIR)/usr/include/tremor/" \
49
+	VORBIS_LIBS="$(TARGET_LDFLAGS) -lvorbis -lvorbisidec" \
50
+
51
+TARGET_CFLAGS += $(FPIC) -Wl,-rpath-link="$(STAGING_DIR)/usr/lib"
52
+
53
+define Build/InstallDev
54
+	$(INSTALL_DIR) $(1)/usr/include
55
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/shout $(1)/usr/include/
56
+	$(INSTALL_DIR) $(1)/usr/lib
57
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libshout.{a,so*} $(1)/usr/lib/
58
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
59
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/shout.pc $(1)/usr/lib/pkgconfig/
60
+	$(SED) 's| -I/usr/include||' $(1)/usr/lib/pkgconfig/shout.pc
61
+endef
62
+
63
+define Package/libshout/install
64
+	$(INSTALL_DIR) $(1)/usr/lib
65
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libshout.so.* $(1)/usr/lib/
66
+endef
67
+
68
+$(eval $(call BuildPackage,libshout))

+ 11
- 0
libs/libshout/patches/120-vorbis-c.patch View File

@@ -0,0 +1,11 @@
1
+--- a/src/vorbis.c
2
++++ b/src/vorbis.c
3
+@@ -28,7 +28,7 @@
4
+ #endif
5
+ #include <stdlib.h>
6
+ 
7
+-#include <vorbis/codec.h>
8
++#include <tremor/ivorbiscodec.h>
9
+ 
10
+ #include "shout_private.h"
11
+ #include "shout_ogg.h"

+ 17
- 0
libs/libshout/patches/140-no_example_doc_win32.patch View File

@@ -0,0 +1,17 @@
1
+--- a/Makefile.in
2
++++ b/Makefile.in
3
+@@ -288,12 +288,12 @@ top_builddir = @top_builddir@
4
+ top_srcdir = @top_srcdir@
5
+ AUTOMAKE_OPTIONS = 1.6 foreign
6
+ ACLOCAL_AMFLAGS = -I m4
7
+-SUBDIRS = include src examples debian doc win32
8
++SUBDIRS = include src debian
9
+ EXTRA_DIST = INSTALL m4/shout.m4 m4/acx_pthread.m4 \
10
+ 	m4/ogg.m4 m4/vorbis.m4 m4/xiph_compiler.m4 m4/xiph_net.m4 \
11
+ 	m4/xiph_types.m4
12
+ 
13
+-doc_DATA = COPYING NEWS README examples/example.c examples/nonblocking.c
14
++doc_DATA = COPYING NEWS README
15
+ m4datadir = $(datadir)/aclocal
16
+ m4data_DATA = m4/shout.m4
17
+ @HAVE_PKGCONFIG_TRUE@pkgconfigdir = $(libdir)/pkgconfig