Browse Source

Backported and update the libtasn1 package.

Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Nikos Mavrogiannopoulos 10 years ago
parent
commit
3a025deb84
1 changed files with 56 additions and 0 deletions
  1. 56
    0
      libs/libtasn1/Makefile

+ 56
- 0
libs/libtasn1/Makefile View File

@@ -0,0 +1,56 @@
1
+#
2
+# Copyright (C) 2005-2008 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=libtasn1
11
+PKG_VERSION:=3.6
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=ftp://ftp.gnu.org/gnu/libtasn1
16
+PKG_MD5SUM:=6ed38e161e11013054f2a2bb4c4da449
17
+
18
+#PKG_FIXUP:=autoreconf
19
+PKG_INSTALL:=1
20
+
21
+include $(INCLUDE_DIR)/package.mk
22
+
23
+define Package/libtasn1
24
+  SECTION:=libs
25
+  CATEGORY:=Libraries
26
+  TITLE:=An ASN.1 and DER structures manipulation library
27
+  URL:=ftp://ftp.gnu.org/gnu/libtasn1/
28
+endef
29
+
30
+define Package/libtasn1/description
31
+ This is a library for Abstract Syntax Notation One (ASN.1) and
32
+ Distinguish Encoding Rules (DER) manipulation.
33
+endef
34
+
35
+TARGET_CFLAGS += $(FPIC)
36
+
37
+CONFIGURE_ARGS += \
38
+		--enable-shared \
39
+		--enable-static
40
+
41
+define Build/InstallDev
42
+	$(INSTALL_DIR) $(1)/usr/bin
43
+	$(INSTALL_DIR) $(1)/usr/include
44
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/libtasn1.h $(1)/usr/include/
45
+	$(INSTALL_DIR) $(1)/usr/lib
46
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libtasn1.{a,so*} $(1)/usr/lib/
47
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
48
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libtasn1*.pc $(1)/usr/lib/pkgconfig/
49
+endef
50
+
51
+define Package/libtasn1/install
52
+	$(INSTALL_DIR) $(1)/usr/lib
53
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libtasn1.so.* $(1)/usr/lib/
54
+endef
55
+
56
+$(eval $(call BuildPackage,libtasn1))