소스 검색

python: move python package versioning to python-package.mk

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Alexandru Ardelean 10 년 전
부모
커밋
3ad7208ba6
2개의 변경된 파일5개의 추가작업 그리고 2개의 파일을 삭제
  1. 4
    2
      lang/python/Makefile
  2. 1
    0
      lang/python/files/python-package.mk

+ 4
- 2
lang/python/Makefile 파일 보기

@@ -7,8 +7,11 @@
7 7
 
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10
+# The file included below defines PYTHON_VERSION
11
+-include $(if $(DUMP),,./files/python-package.mk)
12
+
10 13
 PKG_NAME:=python
11
-PKG_VERSION:=2.7.3
14
+PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
12 15
 PKG_RELEASE:=2
13 16
 
14 17
 PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
@@ -29,7 +32,6 @@ PKG_BUILD_DEPENDS:=python/host
29 32
 
30 33
 include $(INCLUDE_DIR)/host-build.mk
31 34
 include $(INCLUDE_DIR)/package.mk
32
--include $(if $(DUMP),,./files/python-package.mk)
33 35
 
34 36
 define Package/python/Default
35 37
   SUBMENU:=Python

+ 1
- 0
lang/python/files/python-package.mk 파일 보기

@@ -6,6 +6,7 @@
6 6
 #
7 7
 
8 8
 PYTHON_VERSION=2.7
9
+PYTHON_VERSION_MICRO=3
9 10
 
10 11
 PYTHON_DIR:=$(STAGING_DIR)/usr
11 12
 PYTHON_BIN_DIR:=$(PYTHON_DIR)/bin