|
@@ -8,7 +8,7 @@
|
8
|
8
|
include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=gnunet
|
11
|
|
-PKG_SOURCE_VERSION:=36068
|
|
11
|
+PKG_SOURCE_VERSION:=36094
|
12
|
12
|
PKG_VERSION:=0.10.1-svn$(PKG_SOURCE_VERSION)
|
13
|
13
|
PKG_RELEASE:=1
|
14
|
14
|
|
|
@@ -164,6 +164,7 @@ define Package/gnunet/install
|
164
|
164
|
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/gnunet/hellos/* $(1)/usr/share/gnunet/hellos
|
165
|
165
|
$(INSTALL_DIR) $(1)/etc/init.d/
|
166
|
166
|
$(INSTALL_BIN) ./files/gnunet.init $(1)/etc/init.d/gnunet
|
|
167
|
+ $(INSTALL_DATA) ./files/gnunet.upgrade $(1)/lib/upgrade/keep.d/gnunet
|
167
|
168
|
endef
|
168
|
169
|
|
169
|
170
|
define Build/InstallDev
|
|
@@ -173,20 +174,6 @@ define Build/InstallDev
|
173
|
174
|
$(CP) $(PKG_INSTALL_DIR)/usr/include/gnunet/*.h $(1)/usr/include/gnunet
|
174
|
175
|
endef
|
175
|
176
|
|
176
|
|
-define Package/gnunet/postinst
|
177
|
|
-#!/bin/sh
|
178
|
|
-grep -qc "/etc/gnunet" "$${IPKG_INSTROOT}"/etc/sysupgrade.conf >/dev/null ||
|
179
|
|
- echo "/etc/gnunet/" >> "$${IPKG_INSTROOT}"/etc/sysupgrade.conf
|
180
|
|
-
|
181
|
|
-endef
|
182
|
|
-
|
183
|
|
-define Package/gnunet/postrm
|
184
|
|
-#!/bin/sh
|
185
|
|
-grep -qc "/etc/gnunet" "$${IPKG_INSTROOT}"/etc/sysupgrade.conf >/dev/null &&
|
186
|
|
- sed -i '/\/etc\/gnunet/d' "$${IPKG_INSTROOT}"/etc/sysupgrade.conf
|
187
|
|
-
|
188
|
|
-endef
|
189
|
|
-
|
190
|
177
|
DEPENDS_conversation:=+gnunet-gns +libgst1app +libgst1audio +libgstreamer1 +glib2 +pulseaudio-daemon +libopus +libogg
|
191
|
178
|
BIN_conversation:=conversation conversation-test
|
192
|
179
|
LIB_conversation:=conversation microphone speaker
|