|
@@ -0,0 +1,71 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2008-2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=libesmtp
|
|
11
|
+PKG_VERSION:=1.0.6
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+PKG_MD5SUM:=c4fedc999b6c3820296b0eb92cc2e252
|
|
14
|
+
|
|
15
|
+PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
|
|
16
|
+PKG_LICENSE:=LGPL-2.0+
|
|
17
|
+PKG_LICENSE_FILES:=COPYING
|
|
18
|
+
|
|
19
|
+PKG_SOURCE_URL:=http://www.stafford.uklinux.net/libesmtp
|
|
20
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
21
|
+PKG_CAT:=zcat
|
|
22
|
+
|
|
23
|
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
|
24
|
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
|
25
|
+
|
|
26
|
+include $(INCLUDE_DIR)/package.mk
|
|
27
|
+
|
|
28
|
+define Package/libesmtp
|
|
29
|
+ SECTION:=libs
|
|
30
|
+ CATEGORY:=Libraries
|
|
31
|
+ TITLE:=A Library for Posting Electronic Mail
|
|
32
|
+ URL:=http://www.stafford.uklinux.net/libesmtp/
|
|
33
|
+ DEPENDS:=+libpthread
|
|
34
|
+endef
|
|
35
|
+
|
|
36
|
+define Build/Configure
|
|
37
|
+ $(call Build/Configure/Default,--without-openssl)
|
|
38
|
+endef
|
|
39
|
+
|
|
40
|
+define Build/Compile
|
|
41
|
+ $(MAKE) -C $(PKG_BUILD_DIR) \
|
|
42
|
+ DESTDIR="$(PKG_INSTALL_DIR)" \
|
|
43
|
+ all install
|
|
44
|
+endef
|
|
45
|
+
|
|
46
|
+define Build/InstallDev
|
|
47
|
+ mkdir -p $(STAGING_DIR)/usr/include
|
|
48
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/libesmtp.h $(STAGING_DIR)/usr/include/
|
|
49
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/auth-client.h $(STAGING_DIR)/usr/include/
|
|
50
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/auth-plugin.h $(STAGING_DIR)/usr/include/
|
|
51
|
+ mkdir -p $(STAGING_DIR)/usr/lib
|
|
52
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libesmtp.{a,so*} $(STAGING_DIR)/usr/lib/
|
|
53
|
+ $(INSTALL_DIR) $(2)/bin
|
|
54
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libesmtp-config $(2)/bin/
|
|
55
|
+ $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' $(2)/bin/libesmtp-config
|
|
56
|
+endef
|
|
57
|
+
|
|
58
|
+define Build/UninstallDev
|
|
59
|
+ rm -rf \
|
|
60
|
+ $(STAGING_DIR)/usr/include/libesmtp.h \
|
|
61
|
+ $(STAGING_DIR)/usr/include/auth-client.h \
|
|
62
|
+ $(STAGING_DIR)/usr/include/auth-plugin.h \
|
|
63
|
+ $(STAGING_DIR)/usr/lib/libesmtp.{a,so*}
|
|
64
|
+endef
|
|
65
|
+
|
|
66
|
+define Package/libesmtp/install
|
|
67
|
+ mkdir -p $(1)/usr/lib
|
|
68
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libesmtp.so.* $(1)/usr/lib/
|
|
69
|
+endef
|
|
70
|
+
|
|
71
|
+$(eval $(call BuildPackage,libesmtp))
|