소스 검색

luaposix: update to v33.2.1

Signed-off-by: Maxim Storchak <m.storchak@gmail.com>
Maxim Storchak 10 년 전
부모
커밋
4aee8e7574
3개의 변경된 파일32개의 추가작업 그리고 29개의 파일을 삭제
  1. 2
    2
      lang/luaposix/Makefile
  2. 7
    6
      lang/luaposix/patches/100-eglibc-compat.patch
  3. 23
    21
      lang/luaposix/patches/101-disable-curses.patch

+ 2
- 2
lang/luaposix/Makefile 파일 보기

@@ -8,12 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=luaposix
11
-PKG_VERSION:=v33.0.0
11
+PKG_VERSION:=v33.2.1
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=release-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=https://github.com/luaposix/luaposix/archive/
16
-PKG_MD5SUM:=3241c33566542b7563ae001112646af6
16
+PKG_MD5SUM:=aa68b5c07ab1ecea81bb466c81e88056
17 17
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-release-$(PKG_VERSION)
18 18
 PKG_REMOVE_FILES:=aclocal.m4
19 19
 PKG_FIXUP:=autoreconf

+ 7
- 6
lang/luaposix/patches/100-eglibc-compat.patch 파일 보기

@@ -1,7 +1,8 @@
1
-diff -Naur luaposix-release-v33.0.0.orig/ext/posix/unistd.c luaposix-release-v33.0.0/ext/posix/unistd.c
2
---- luaposix-release-v33.0.0.orig/ext/posix/unistd.c	2014-11-04 17:49:35.000000000 +0200
3
-+++ luaposix-release-v33.0.0/ext/posix/unistd.c	2014-12-14 00:59:14.878622722 +0200
4
-@@ -526,6 +526,7 @@
1
+diff --git a/ext/posix/unistd.c b/ext/posix/unistd.c
2
+index 9276640..69c8cef 100644
3
+--- a/ext/posix/unistd.c
4
++++ b/ext/posix/unistd.c
5
+@@ -525,6 +525,7 @@ Pgetgroups(lua_State *L)
5 6
  #endif
6 7
  
7 8
  
@@ -9,7 +10,7 @@ diff -Naur luaposix-release-v33.0.0.orig/ext/posix/unistd.c luaposix-release-v33
9 10
  /***
10 11
  Current logged-in user.
11 12
  @treturn[1] string username, if successful
12
-@@ -538,6 +539,7 @@
13
+@@ -537,6 +538,7 @@ Pgetlogin(lua_State *L)
13 14
  	checknargs(L, 0);
14 15
  	return pushstringresult(getlogin());
15 16
  }
@@ -17,7 +18,7 @@ diff -Naur luaposix-release-v33.0.0.orig/ext/posix/unistd.c luaposix-release-v33
17 18
  
18 19
  
19 20
  /***
20
-@@ -1037,7 +1039,9 @@
21
+@@ -1044,7 +1046,9 @@ static const luaL_Reg posix_unistd_fns[] =
21 22
  	LPOSIX_FUNC( Pgetegid		),
22 23
  	LPOSIX_FUNC( Pgeteuid		),
23 24
  	LPOSIX_FUNC( Pgetgid		),

+ 23
- 21
lang/luaposix/patches/101-disable-curses.patch 파일 보기

@@ -1,22 +1,12 @@
1
-diff -Naur luaposix-release-v33.0.0.orig/ext/posix/posix.c luaposix-release-v33.0.0/ext/posix/posix.c
2
---- luaposix-release-v33.0.0.orig/ext/posix/posix.c	2014-11-04 17:49:35.000000000 +0200
3
-+++ luaposix-release-v33.0.0/ext/posix/posix.c	2014-12-14 01:49:44.486562194 +0200
4
-@@ -11,7 +11,6 @@
5
-  */
1
+diff --git a/configure.ac b/configure.ac
2
+index dfd4199..19924d0 100644
3
+--- a/configure.ac
4
++++ b/configure.ac
5
+@@ -153,15 +153,6 @@ AC_CHECK_LIB([rt], [clock_gettime])
6
+ AC_SUBST([LIBRT], [$LIBS])
7
+ LIBS=$save_LIBS
6 8
  
7
- #include "ctype.c"
8
--#include "curses.c"
9
- #include "dirent.c"
10
- #include "errno.c"
11
- #include "fcntl.c"
12
-diff -Naur luaposix-release-v33.0.0.orig/configure.ac luaposix-release-v33.0.0/configure.ac
13
---- luaposix-release-v33.0.0.orig/configure.ac	2014-11-04 17:49:35.000000000 +0200
14
-+++ luaposix-release-v33.0.0/configure.ac	2014-12-14 01:58:08.214554482 +0200
15
-@@ -109,15 +109,6 @@
16
-   AC_SUBST([LIBRT], [-lrt])
17
- fi
18
- 
19
--dnl Curses
9
+-## Curses
20 10
 -AX_WITH_CURSES
21 11
 -AC_ARG_VAR(CURSES_LIB, [linker flags for curses library])
22 12
 -
@@ -25,6 +15,18 @@ diff -Naur luaposix-release-v33.0.0.orig/configure.ac luaposix-release-v33.0.0/c
25 15
 -AC_CHECK_FUNCS([resizeterm])
26 16
 -LIBS=$save_LIBS
27 17
 -
28
- dnl Lua 5.1 or 5.2
29
- AX_PROG_LUA(5.1, 5.3)
30
- AX_LUA_HEADERS
18
+ ## Use system implementation, or bundled replacement?
19
+ AC_CHECK_FUNCS([strlcpy])
20
+ 
21
+diff --git a/ext/posix/posix.c b/ext/posix/posix.c
22
+index 6019df0..2d75487 100644
23
+--- a/ext/posix/posix.c
24
++++ b/ext/posix/posix.c
25
+@@ -12,7 +12,6 @@
26
+ 
27
+ #include "bit32.c"
28
+ #include "ctype.c"
29
+-#include "curses.c"
30
+ #include "dirent.c"
31
+ #include "errno.c"
32
+ #include "fcntl.c"