|
@@ -1,22 +1,12 @@
|
1
|
|
-diff -Naur luaposix-release-v33.0.0.orig/ext/posix/posix.c luaposix-release-v33.0.0/ext/posix/posix.c
|
2
|
|
---- luaposix-release-v33.0.0.orig/ext/posix/posix.c 2014-11-04 17:49:35.000000000 +0200
|
3
|
|
-+++ luaposix-release-v33.0.0/ext/posix/posix.c 2014-12-14 01:49:44.486562194 +0200
|
4
|
|
-@@ -11,7 +11,6 @@
|
5
|
|
- */
|
|
1
|
+diff --git a/configure.ac b/configure.ac
|
|
2
|
+index dfd4199..19924d0 100644
|
|
3
|
+--- a/configure.ac
|
|
4
|
++++ b/configure.ac
|
|
5
|
+@@ -153,15 +153,6 @@ AC_CHECK_LIB([rt], [clock_gettime])
|
|
6
|
+ AC_SUBST([LIBRT], [$LIBS])
|
|
7
|
+ LIBS=$save_LIBS
|
6
|
8
|
|
7
|
|
- #include "ctype.c"
|
8
|
|
--#include "curses.c"
|
9
|
|
- #include "dirent.c"
|
10
|
|
- #include "errno.c"
|
11
|
|
- #include "fcntl.c"
|
12
|
|
-diff -Naur luaposix-release-v33.0.0.orig/configure.ac luaposix-release-v33.0.0/configure.ac
|
13
|
|
---- luaposix-release-v33.0.0.orig/configure.ac 2014-11-04 17:49:35.000000000 +0200
|
14
|
|
-+++ luaposix-release-v33.0.0/configure.ac 2014-12-14 01:58:08.214554482 +0200
|
15
|
|
-@@ -109,15 +109,6 @@
|
16
|
|
- AC_SUBST([LIBRT], [-lrt])
|
17
|
|
- fi
|
18
|
|
-
|
19
|
|
--dnl Curses
|
|
9
|
+-## Curses
|
20
|
10
|
-AX_WITH_CURSES
|
21
|
11
|
-AC_ARG_VAR(CURSES_LIB, [linker flags for curses library])
|
22
|
12
|
-
|
|
@@ -25,6 +15,18 @@ diff -Naur luaposix-release-v33.0.0.orig/configure.ac luaposix-release-v33.0.0/c
|
25
|
15
|
-AC_CHECK_FUNCS([resizeterm])
|
26
|
16
|
-LIBS=$save_LIBS
|
27
|
17
|
-
|
28
|
|
- dnl Lua 5.1 or 5.2
|
29
|
|
- AX_PROG_LUA(5.1, 5.3)
|
30
|
|
- AX_LUA_HEADERS
|
|
18
|
+ ## Use system implementation, or bundled replacement?
|
|
19
|
+ AC_CHECK_FUNCS([strlcpy])
|
|
20
|
+
|
|
21
|
+diff --git a/ext/posix/posix.c b/ext/posix/posix.c
|
|
22
|
+index 6019df0..2d75487 100644
|
|
23
|
+--- a/ext/posix/posix.c
|
|
24
|
++++ b/ext/posix/posix.c
|
|
25
|
+@@ -12,7 +12,6 @@
|
|
26
|
+
|
|
27
|
+ #include "bit32.c"
|
|
28
|
+ #include "ctype.c"
|
|
29
|
+-#include "curses.c"
|
|
30
|
+ #include "dirent.c"
|
|
31
|
+ #include "errno.c"
|
|
32
|
+ #include "fcntl.c"
|