Browse Source

shairplay: update to latest version

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Álvaro Fernández Rojas 9 years ago
parent
commit
52e2f0e80b
2 changed files with 6 additions and 19 deletions
  1. 4
    4
      sound/shairplay/Makefile
  2. 2
    15
      sound/shairplay/patches/003-fix_big-endian.patch

+ 4
- 4
sound/shairplay/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2015 OpenWrt.org
2
+# Copyright (C) 2014-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -8,13 +8,13 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=shairplay
11
-PKG_VERSION:=2014-10-27
12
-PKG_RELEASE:=2
11
+PKG_VERSION:=2015-09-29
12
+PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE_PROTO:=git
15 15
 PKG_SOURCE_URL:=git://github.com/juhovh/shairplay.git
16 16
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
17
-PKG_SOURCE_VERSION:=64d59e3087f829006d091fa0d114efb50972a2bf
17
+PKG_SOURCE_VERSION:=498bc5bcdd305e04721f94a04b9f26a7da72673f
18 18
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
19 19
 PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
20 20
 

+ 2
- 15
sound/shairplay/patches/003-fix_big-endian.patch View File

@@ -1,24 +1,11 @@
1 1
 --- a/src/lib/alac/alac.c
2 2
 +++ b/src/lib/alac/alac.c
3
-@@ -29,11 +29,7 @@
3
+@@ -29,7 +29,7 @@
4 4
   *
5 5
   */
6 6
  
7
--#ifdef __BIG_ENDIAN__
8
--static const int host_bigendian = 1;
9
--#else
10 7
 -static const int host_bigendian = 0;
11
--#endif
12
-+static int host_bigendian = 0;
8
++#define host_bigendian (htonl(42) == 42)
13 9
  
14 10
  #include <stdio.h>
15 11
  #include <stdlib.h>
16
-@@ -1181,6 +1177,8 @@ alac_file *create_alac(int samplesize, i
17
- {
18
-     alac_file *newfile = malloc(sizeof(alac_file));
19
- 
20
-+    host_bigendian = (htonl(42) == 42);
21
-+
22
-     newfile->samplesize = samplesize;
23
-     newfile->numchannels = numchannels;
24
-     newfile->bytespersample = (samplesize / 8) * numchannels;